Apple TV Gen 1 HDMI issue, any ideas?

Sorry, I know that this doesn't relate to aTV Firecore, but I am a long term aTV Firecore user and hope someone here can assist. 

I have 3 x Apple TV Gen 1 units and they have all worked perfectly well in various parts of the house for as long as I've owned them. Until the other day. One of them has no HDMI output. 

Google search brought up a few posts suggesting that on early units the HDMI could fail (either video or audio output failing) and simply rewinding and updating would solve the problem. However, no! 

The only output I can get to work is via component cables, which is a bit frustrating. 

Anyone had this experience? Any further ideas? 

Thanks in advance. 

If the issue is present after a full restore and update it's most likely a hardware issue.  :(

Any AppleCare left on the affected unit?

Sadly no. I have tried everything and discovered that the optical output is also faulty. It looks like the digital aspect of the MBD has become faulty, which is plain odd as I’d have imagined that they’d have been completely separate (video / audio).

Just using it as a spare via component and it’s fine, but I can never sell it.