apple tv device not eligible for this build 4.3

Hi I bought an apple tv yesterday and updated to 4.3 without noticing until it was too late.  No worries, I thought, seas0n pass can still jailbreak it.  However, I keep coming up with the "apple tv was not restored.  Device not eligible for this build" error message, even though I've restored using signed software.  Any thoughts?

I have the same problem. I tried mac and windows versions of seass0npass, with same error messages. Any suggestions?

I face the same message!

I finally did it! I could jailbreak my apple tv 2g by using the mac version of Seass0npass. I really don't know why it works this time. I just delete the previously patched IPW file and restart the process. To get DFU mode I use the alternative method: Connect USB and power and press menu+down during 6 seconds or so (until light flashing), and then press menu+play during other 6 secons or so (again until light flashing). I tried this 2 or 3 times and finally it works. I also change my host file, but I am not sure if this is necessary. Good luck!