Apple TV crashing with MEGA

Every time I ask infuse to fix this issue, they say that an update is available but the issue is never fixed, and the Apple TV app always crashes. It works flawlessly on the iPad OS and iOS apps. I’m not sure how this is even tested, but the issue clearly has never been fixed.

Have you just dealt with this? Or have you migrated your data elsewhere. I bought an NVIDIA shield not too long ago and tried the whole Plex ordeal. So many issues. Infuse is so much easier. I have spent so much time uploading gigabytes of data to MEGA specifically for infuse - only for this to happen. I wonder if this issue is specific to MEGA or if I should just migrate to Gdrive or somewhere else.

There was no other way I could deal with it, have plenty of data on mega as well. It’s just super convenient and the fact that it works fine with iPadOS is where this gets me. I have a feeling there is some memory issue going on when it’s trying to cache gigabytes of data on infuse; something that is better managed on iOS/iPadOS. Right now, just watching it on my ipad……

There are regular updates to infuse but there hasn’t been any work that I’ve seen regarding Mega. You can track the release notes here

And upcoming releases in this thread

We’re currently looking into this issue.

Stay tuned…

Thanks James! :slight_smile:

I appreciate the response James! We hope to see a resolution soon :slight_smile:

Look forward to a permanent resolution!

We have a potential fix for this available in a beta version in TestFlight.

If anyone would like to try this, please drop me a PM.

I don’t use MEGA but have the same issue with crashing. I would be willing to give the test flight a try.

This is targeting users with MEGA accounts. You may want to start a new thread and explain what you’re seeing.

Thank you. I’ve already been in contact with firecore tech support via email but the issue was so similar it could still be related. If the Beta solves my issue then it may lead to solving yours as well? My issues seemed to have started with the same IOS releases and persist through the same infuse releases.

Is your problem with the Apple TV or an iOS device?

Apple TV. Sorry, I meant TVOS releases.

James, I’m not sure what happened. But Infuse has been working for the past 2 days on ATV. It hasn’t crashed at all. If I see the issue again, I’ll reach out for the beta - right now I’m not seeing it

Hi James, I’m still having the same issues :frowning:

I’m willing to do some beta testing if needed.

Today’s 7.3.10 update includes some fixes for a few issues with MEGA we’ve found.

There is also a bug in the MEGA SDK which we’ll be working with MEGA to resolve, and I will post more info once it’s available.

Hi James. I just tried the official AppStore version and it looks like MEGA was briefly recognized but the app started crashing again. It’s a step in the right direction because I wasn’t even able to see the library sync before. Now, right before I play any file, it crashes. Hard to send the diagnostic because it reps crashing but maybe it’s that MEGA SDK bug you mentioned?

Did this ever get a solution?

I’ve been using MEGA for the past several months with no issues on Mac, IOS, and AppleTV