Apple TV crashing with MEGA

Hi all!

I’m having a returning problem of the INFUSE app crashing on AppleTV a few seconds after launching. I was finally able to submit diagnostics before the app crashed. The code is 3SB4A

Any idea what’s going on?

I’m afraid it has something to do with MEGA as the problems started since I moved my media collection to MEGA. Infuse app on iPhone and iPad work with MEGA without any issues though.

So far I’ve tried to restart the AppleTV, delete and reinstall app but to no avail.

Any tips?

Thanks all!

Looking into this. Thanks.

Thanks for looking into it, James! Any update yet?
The Infuse app now crashes every time I try to open it on the appletv and won’t work at all… :frowning: Mind you: no issues with infuse app on iPad, iPhone or Mac!

I have continued to troubleshoot myself but still no luck. I’ve removed and re-added my MEGA drive to Infuse, updated the tvOS and even reset the AppleTV to start from scratch… Problem persists. Last resort: I ordered the latest AppleTV (4K 2021) and should receive it later today. Hope that fixes the issue but honestly, not too hopeful since resetting my current AppleTV (HD) did not work either…

If the infuse app won’t work with our appletv anymore, it basically renders it useless for us since we basically use the AppleTV exclusively with the Infuse app. So really hope we can find a fix for this. Fingers crossed!

Don’t want to send you off on a wild goose chase but do other apps on this ATV run without problems?

How many other non apple apps do you have on it?

How are you connected to your LAN? WiFi or Ethernet? Have you tried changing this?

Thanks for the follow up.

I have no issues with other apps. Only others apps we occasionally use on the appletv are Netflix and amazon prime but that’s about it.

Just set up the new appletv (4k 2021) and set it up as a new device but the issue persists. Even connected through ethernet but didn’t change.

Some further troubleshooting shows it has all to do with MEGA. As soon as I remove the MEGA drive (via infuse app on iPad) and let infuse on appletv sync, the infuse app on the appletv does not crash anymore. The moment I add MEGA again and it syncs => crash every time the moment I open it.
The only way to get the infuse app to work on appletv again is to remove MEGA from infuse via another device… so frustrating!

It used to work up until a few days ago. I had the exact same problem around Christmas and even posted on this forum (Issue with MEGA since morning of 12/24/21) but then it miraculously started workin again 24 hours later. At the time I thought it was related to a tvOS update but my appletv (also the new one) is running the latest tvOS.

Any idea why infuse on appletv won’t work with MEGA but infuse apps on all other devices are just fine?

Any update on this?
Am I the only one with this issue?

Does Infuse 6 have the same issue? If not, I’m willing to switch from an infuse 7 subscription to a one time purchase of Infuse 6 if that means I can watch my files stored on my MEGA drive via our AppleTV. But I 'd like to know before I make the investment…

Thanks all!

A fix for this will be available soon in the 7.3.4 update.

Thanks for your patience.

Great! Thanks James! I’m ecstatic! :grin:

This should be resolved in today’s 7.3.4 update.

Thanks for your patience.

Hi James

the problem started again yesterday (Sunday 20 Feb) :frowning:

I’ve gone through the usual troubleshooting as described in earlier posts to make sure the cause lies nowhere else.

I’ve just spent over an hour trying to get an error code but the AppleTV Infuse app crashed less than a second after opening it so I can’t get to it. Removed MEGA-drive via the iPad app, allowed iCloud to update but the infuse app on appletv won’t get to updating with iCloud and so keeps crashing on launch…

I even disconnected appletv from internet which then allows the app to open without crashing but then I cannot upload the error code… The only way to get the app to work again is to delete it from the appletv and reinstall it but then the error is gone and cannot be uploaded…

Any help? I was so happy that it worked again. Hope you guys can find a solution quickly!

Thanks in advance!

Seems fixed again in update 7.3.5 (22 Feb).

Thanks y’all! :smiley:

1 Like

Hi all

the same issue resurfaced this morning :frowning:
Infuse app on AppleTV crashes immediately upon starting. Cannot even get to the error code…
As usual, no problems with infuse app on all other devices.

Went thru the usual troubleshooting including updating tvOS (15.4) but the problem persists. Again, MEGA seems to be the issue.

  • Is this issue related to tvOS updates? Though I only updated after I noticed the issue this morning…
  • And does that mean this issue will continue to resurface each time there’s a tvOS update?

When can we expect a new infuse update? Can I assume it will be fixed with the next infuse update?

Thanks again y’all!!

Omg thank you for bringing this up and following this so closely. I’ve raised several issues with the team to fix this, and have the same issue of the Apple TV app crashing ONLY on my Apple TV (pre-2021) but working on my iPad/iPhone devices. The issue is still there, dunno if it’s because of MEGA (folder having too many files?), or just the app not working well on Apple TV (memory running out? No idea).

Really hope there is permanent fix to this, Firecore, please respond.

What version number of Infuse are you running?

Just updated to 7.3.7 but that didn’t fix the issue yet :frowning:

Any idea when we can expect a fix this time?

Thanks in advance!

Hi all

Any update on this?

Thx!

Still having the same issue on my side. This issue hasn’t been fixed =( Any updates infuse team?

Since I accidentally installed 7.3.7 on 15.4 tvOS, I’ve been having all sorts of playback start problems on my Plex shares. I’ve had spinners running for a while before start, and spinners that never start playback. I’ve also seen Infuse get into a state where it wouldn’t try to start, and I had to either reboot, or kill the running Infuse and start it again.

Not sure if helpful, but I uploaded a diagnostic:
xv6tx

Issue with MEGA not fixed in update 7.3.8.

Any idea when we can expect a fix?

Same issue, and honestly very disappointed.

I just bought an ATV 4K this weekend specifically for infuse and after uploading over 500gb of media to Mega and purchasing their subscription. I purchased Infuse Pro and it has been working flawlessly on iPhone/Mac. Pushed me to buy an ATV

The first day of use worked perfectly. Yesterday and today it has been crashing within 2 seconds of opening the app. I tried for about 20 minutes to get to crash reports but it closes too fast for me to even get near it. I have restarted several times, re-installed infuse, etc and issue persists. It honestly feels like such a waste, I really want this to work. It looks like this has been an ongoing issue over several versions - any idea when this will actually get fixed?

Infuse Version 7.3.8 (current)
tvOS 15.4.1 (current)