Apple TV connection issue

I cannot connect to my MAC shared library via Apple TV.

although it sees the folders but no files

What protocol are you using to connect? SMB, FTP, DLNA, etc.?


There’s a good users guide here that has info on set up and trouble shooting.

I read that. I could connect with my previous Apple TV. got the new Apple TV and connect see videos. please help. I am a pro subscriber

I read that. I could connect with my previous Apple TV. got the new Apple TV and unable to see videos on Apple TV - it is empty. please help. I am a pro subscriber

There are a few things to check.

  1. SMB is enabled on your Mac (more info here Set up file sharing on Mac - Apple Support)
  2. At least one user is selected under ‘Windows File Sharing’ (as shown under ‘Advanced Options’ in the link above)
  3. The folders/drives you wish to share are added to the list of Shared Folders
  4. Selected username and password are being entered in Infuse

If you’ve recently installed an update for macOS, you may need to disable and then re-enable File Sharing to get it working again. You can also try one of the tips found here.

Note: iCloud username/password cannot be used. If you’re using an iCloud ID to log in to your Mac, you will need to set up a new ‘Sharing Only’ user as described here: Change Users & Groups settings on Mac - Apple Support

I tried all this steps. nothing allows me to connect from my Apple TV to my Mac via infuse.
infuse is working fine on my Mac.

what else please?

I still cannot connect. can you advise please

I need help. so frustrated. my Apple TV infuse does not connect to smb Mac mini

please help.

I also get message on infuse appletv indexing failed

Same issue. Infuse see’s my Drobo NAS files fine on my Mac, but when it comes to AppleTV it sees the folders but says they are all empty.

Have you walked through the steps posted above? SMB streaming from Mac needs to be enabled in kind of a specific way, so if you miss one of these it can lead to connection issues like this.

Also (and this may be a silly question) but can you confirm you have video files stored on your Drobo? Other files like audio or PDFs won’t be visible in Infuse.

Yes, I have multiple types of video files on the Drobo. If I use Infuse on my Mac it sees the files properly and can play them. Try it a few minutes later on AppleTV and it says the folders are empty.

Somehow this worked its self out.

1 Like