Apple TV Audio Silent Until Rewind (w/ Wireless Audio Sync enabled)

No luck with that either unfortunately. I might try a full reset of the Apple TV and see if that solves the issue. I saw a few other users on Reddit forums experiencing the same things so I believe it may have been the Apple TV OS update that changed something.

@james just to give an update, it seems that if I turn off match frame rate in the Apple TV settings, movies and shows play as expected without me needing to select the audio track or rewind to get sound back.

So this seems to be an issue with the initial frame rate switch the Apple TV is doing. Maybe Apple changed something with frame rate switching in TvOS 14.7? This doesn’t happen on any other apps I have installed though (Plex client or ATV plus).

Was this issue only on 14.7 or are you saying there is a workaround with 14.7?

I’m assuming either tvOS14.7 was the issue but it could be the infuse update that caused the issue as well. As I can’t “downgrade” tvOS or Infuse 7 I’m merely just guessing as to which caused the issue for me.

Does this not happen to you? Did you update infuse and apple tv to the latest version?

Have the same issue. Not isolated to infuse though and started with upgrade to tvOS 14.6. Problem seems to be widespread.

Update: Downloaded today’s 7.0.5 update and launched the app. First movie I played the audio started as one would expect with no issues.

Next video I played however the player reverted back to the same issue (no audio until rewind or manually selecting the audio stream again).

Tried bluetooth as well and the audio initially worked, then reverted back to the previous behavior. At least the app is working on tvOS15 beta so all good there! But this problem unfortunately still persist. @james

Have the same issue with the audio stream in Infuse after upgrading to tvOS 14.7…
There seems to be only a workaround - the proposed rewind and forward back payback.
Wondering when this issue will be addressed by Firecore…

I have exactly the same issue - and exactly since updating to tvOS 14.7 yesterday morning, never had it before. The problem only seems to occur on the new Apple TV 4K (2021). My older Apple TV 4K (2017) still plays the audio instantly. But the new one doesn’t. I’m using the latest Infuse version and tvOS 14.7 on both Apple TVs, so unless Infuse wasn’t updated the night before with the update being buggy, I’d say something was changed in tvOS 14.7 that Firecore hasn’t accounted for yet.

@rashkovan : there is another workaround for the time being - just select the audio track again in the swipe-down menu while the movie/show plays. I personally find this more convenient than rewinding.

Firecore, please look into this, this is really annoying!


Same problem with my 4K with the same config (multiple Apple TV) and framework updated.

Anytime a new episode starts to play, video is going but audio is mute.
I always have to restart playing the episode and then the audio will work.

I’m using both latest tvOS 14.7 (but I already had this problem before the update) and Infuse versions.

I moved your post to a currently running thread on this problem. It’s currently being researched so keep your fingers crossed for a quick fix. :wink:

Thank you, just sent diagnostic logs: ACTDK

1 Like

@Taucheranzug thanks for sharing this workaround! Indeed - much more convenient :smile:

I cross my fingers that Firecore will quickly find a solution and fix this problem.


Quick update.

We’ve been looking into this issue, but have not yet been able to replicate this in any of our setups (it seems it may only appear under certain conditions with certain TV models).

To troubleshoot this further, we have prepared a special build for TestFlight with some extra logging which should allow us to gather more info here.

If you are willing to install this build and run a few tests please let me know.

It would also be helpful if you’re able to share details of your device setup

  1. A list of the device(s) the Apple TV is connected to
  2. The current option selected in Apple TV Settings > Video and Audio > Audio Format



  1. Install Infuse 7.0.9 (3758)
  2. Reproduce the issue and play a video without audio for about 10-15 sec
  3. Seek to the beginning of the video
  4. Play the video with sound for 10-15 sec
  5. Submit a report via Settings > Submit Diagnostics and post the code here
1 Like


I’m OK to make some tests.

1 Like

Invite sent. :slight_smile:

Count me in… Although my issue started from IOS 14.6 and more widespread than just Infuse

I just upgraded my TV and soundbar to the Vizio Oled H1 plus Dolby Atmos soundbar recently, and the issue is gone for me now. I was previously on a 1080p Samsung with optical soundbar connection. If some of you can share your TV/Audio setups that might help identify the issue?

I watched several TV shows yesterday on the current Infuse build and TVOs 15 beta and all is working well!

Only issue I had was laggy framerate on 1 episode but I’m in the TVos beta so I’m sure it’s related to that.

1 Like

Apple TV A1842 (32Go) with tvOS 15.0 (19J5304d) and the Audio Format is set to “Auto”.
TV Samsung UE55KU6400

Here is the code of my report RQRYF

1 Like

@james I’d like to participate in the testing as well. QQ - how I can install Infuse 7.0.9 (3758) on my Apple TV? Upon checking in AppStore, the latest version is 7.0.8 (3737)
Thanks, Grigory