Apple TV 5.3 not loading Home Screen apps

I Jailbroken my Apple TV with the new unthetered version of 5.3

But now My Apple TV refuses to set automatically date and time and won’t load any App in home screen, the connection works fine with XBMC.

I don’t know if this has anything to do with OPENWRT i recently installed on my router…

Any help appreciated.

 

Sounds like you are not connected to a network, if you are not connected to one the aTV will not load the home screen apps! If you are connected to a network make sure you can access the internet.

Good luck

Leeroy

[quote="leeroy"]

Sounds like you are not connected to a network, if you are not connected to one the aTV will not load the home screen apps! If you are connected to a network make sure you can access the internet.

Good luck

Leeroy

[/quote]

 

He wrote " the connection works fine with XBMC." so he must be connected to the internet.

 

As far as your problem edemir, I don't know what's going on.

[quote="Carpenter940"]

He wrote " the connection works fine with XBMC." so he must be connected to the internet.

[/quote]

Not necessarily;y true.  there may be some obscure issue where there is a local LAN connection but no internet connection.   The Home screen icons not appearing is almost invariably due to the fact that the ATV cannot contact the Apple severs which is why it suggests a network issue.   It can also happen if by any chance the Apple servers themselves are having issues.

I don't have network issues with anything else, I just jailbroken my ATV 2 and blocked apple updates using hosts file.

Really don't understand why this happening.

[quote="edemir"]

I don't have network issues with anything else, I just jailbroken my ATV 2 and blocked apple updates using hosts file.

Really don't understand why this happening.

[/quote]

I jailbroke my ATV2 2 weeks ago and didn't block apple updates using hosts files and it worked perfectly.

That is most probably your issue.  Once jailbroken it automatically stop trying to update.

Remove those entries, and try again ;)

EDIT - Sorry ignore this, as I realise this is part of the script to block apple within the host file.

I just had the exact same thing happen! i jailbroke, sat here for what seemed like a solid hour waiting for the atv to activate and finally hit the menu button and the homescreen shows up with just the computer icon and the fc settings icon. Tried to install xbmc through terminal, worked perfectly, added repos and add-ons, worked perfectly, even watched some tv on 1channel, works perfectly. But....i still dont have my homescreen. Any suggestions or are we hooped?

Sign in to your itunes account and your network and that should bring up the homescreen icons!

[quote="leeroy"]

Sign in to your itunes account and your network and that should bring up the homescreen icons!

[/quote]

Thanks anyway Leeroy, but my atv2 says that it can't sign in until it sets the date and time :( and since the jailbreak wont let it contact apple at all I'm kinda stuck.

I have the same problem

See guys, i'm not the only one with this problem, anyone else got it solved ? Is apple blocking jailbroken ATVs ?

[quote="edemir"]

See guys, i'm not the only one with this problem, anyone else got it solved ? Is apple blocking jailbroken ATVs ?

[/quote]

 

Mine's fine

I have the same problem. My ATV2 cant set time/date.
Read a lot of posts on different forums without coming to a solution that works :-(
One thing I've been successful with a couple of times is:
- Removing the ethernet cable (auto switching to wifi)
- Power cycle ATV2
- Reconnect ethernet cable
- For some reason the ATV2 finds it way "back" to life and it signs in again to Applestore

But seriously this is not a proper solution :-( Hope somebody finds a solution to a problem that many people are reporting!!
 

Hi.

Had the same: make sure you have your Itunes account “logged” in correctly on your ATV. That worked for me.

No solution, sorry. But somehow this issue is related to the router, I think. I have the same problem. I have an Apple TV 2 jailbroken, and it will not load the icons properly. Usually this means that there is a problem with the internet connection. XBMC works fine, though.

I have tried the same Apple TV on a different router at a friends place, and here there is no problem. Maybe, this is because he has set up his router with a DNS server address. I will try this out and post my results here.

Mean while, if anybody else has found the solution, I will be most thank full to hear about it.