Apple TV 5.0 need to restore to older version - Help!

Hey guys,

 

 I am fairly new to this AppleTV2. I had previously jail broke my AppleTV2 with Seasons Pass.

Out of curiosity I wanted to see what the new version of AppleTV2 version 5.0 was like.  Not as impressed as I thought.

My problem now is restoring my AppleTV back to an older version.

How do I restore it? I tried using Season Pass but when Season Pass opens up iTunes to restore to version 4.4.4

It goes through as the restore points and then the message comes up " The Apple TV “Apple TV” could not be restored. The device isn’t eligible for the requested build.

 

Can anyone help?

Did you keep the SSH blobs (signatures) for your previous version of firmware? If you did not then you cannot go back.

Yes I had saved them. I was finally able to get the latest version of Seasonpass to run iTunes without failing. The old Firmware 4.4.4 is now installed on the AppleTV2 followed by ATV2 Black.
Thanks for your reply.

I had this problem too.

 

I saved my SHSH blubs via tiny url.

I had heaps of issues trying to go back until I swore and cursed and threatened to replace it, then it started to downgrade

I’m stuck in this predicament now too, though in my case my previously jailbroken ATV2 got stuck with only the Apple log showing on the screen, then when  tried to fix it- it got stuck in DFU mode, and nothing- I MEAN NOTHING, I tried would fix it, except when I finally gave up and upgraded it to the latest iOS.

I’ve been trying to downgrade it (yes all SHSH Blobs are saved), but nothing works, it keeps getting stuck in DFU mode and then I can’t get it out until I upgrade to iOS 5 again.

So- is there anything you can think of that you may have done slightly different in order to finally downgrade your units, as it is now my ATV2 is essentially useless to me, and I may be forced to get some other device to watch my shows instead.

Any thoughts would be appreciated seeing as how I’ve been at this for two days straight (good thing I’ve been sitting on the couch sick for the last few days).

 

TIA

I had this issue and yet to get a reply from fire core. the new 5.0 version sucks, and I’m annoyed. I sold my ATv2 it was working with the JB and all due to ATV3 came out. then was told it will be some months before ATV3 will be hacked. So i went and bought another ATV2 last week and that is when 5.0 came out.

 

I backed up my first ATV2 to the cloud but now my new ATV2 cannot access it, i have asked fire core on how to backtrack to a previous version and I’m still waiting a reply 10 days on.

Its easier to back track windows then it is with this JB… i just wish they placed a sticky on how to get to the previous version as i want plex. like why the hell update to 5.0 when plex isn’t available.  

Stupid, stupid, stupid idea. If you update something make sure it works or have the previous version readily available for us all to go back to until 5.0 is bug free…

You say that you bacled up the previous version?   Do you mean the blobs or something else?   If the blobs how did you back them up?

I backed up the older version in ATV2 in the Settings. 

Under Maintenance there is a choice of backing up older versions. I am not sure exactly sure but it is saved in the cloud. When you try to restore to an older version using Seasonpass it somehow finds the older version.