Apple TV 4K, MacMini, 4K movie impossible to watch

Hi there,
I find about infuse because I was looking for a way to play my 4k files and Plex was alway transcoding them. My macmini always went up to 250%+ CPU without being able to play anything.

So I found out about Infuse and gave it a try.
I discovered that to play UHD files i have to buy the premium version. Which would be fine if I were capable of playing it.

I’m trying right now:
3/4 seconds of play, 15/30 seconds of spinning wheel. Am I missing something? The macmini isn’t supposed to be the problem since it should be “direct play” with no transcoding.
I’m more than happy to pay the monthly fee if I understand where the problem is and how to fix it. So far the experience is very frustrating.


Sou you are sharing the files via your mac mini and are trying to play them via appletv4k? Or how do I understand your setup? Apple TV is connected wireless or wired? What kind of network are you using?

maybe if you give a bit more Info someone has an idea on how to help.

Thanks in advance.

Hi there,
sorry for the vague request,
it was 2 in the morning after 3 hours of trial and error and I was kind of frustrated.

This my setup:

  • a mac mini (not latest model) with plex media server and some 4K files (between 30 and 70GB each)
  • an apple tv 4k
  • a wifi network
  • a 100Mb ADSL

The ATV is connected via wifi and I use it to watch Netflix’s 4K content without any problem.

Do I need to change my setup?


As a quick test, could you connect via an Ethernet cable to the ATV so all connections are wired?

Also, how are your shares connected? SMB (if so what level 1, 2, 3, auto) FTP, DLNA etc.

Edit to add: Are you using an ATV4K or ATV4?

I cant say for sure but Wifi might be a problem here. also the fact the your CPU is totally under water performance wise might be an indicator that your plex server is actually transocding the files before streaming them which makes up for the cpu stress and bad streaming performance.

Your Setup should be able to share those files (best via nfs) and then to direct play them via the infuse app. Should work like a charm given the right setup and connections.

Can you confim your % of cpu usage during all those tries you did? if its all they way up / at the limit of the macmini cpus ressources the plex server should be the source of the problem (transcoding).

The Mac mini shouldn’t be the issue since it’s not having to transcode anything for infuse like it was using plex. All it’s doing is serving files. Also, SMB works fine in most cases and usually is easier to set up and maintain.

I’m using a ATV4K.
I need to try with an Ethernet cable but is the ATV going to be able to be connected to the wifi for other content (eg Netflix)?
Or I’ll need to plug/unplug the Ethernet cable all the time?

About “SMB (if so what level 1, 2, 3, auto) FTP, DLNA etc.” I’ve no idea on how to know that, sorry.
If you help me with that I’ll tell you right away.


I can confirm you that via Plex on the ATV the CPU goes all the way to 300%.
With Infuse no sign of CPU problem, but the content is super buffering all the time.

You may be able to stay with wifi if the protocol you’re using can be tweaked a bit. Otherwise, you may find it better to work with wired cables for all connections from your internet, router, and ATV. How do you have your internet connection to your Mac now?

First, check to see what protocol you’re using.

Go to this users guide and it will explain the set up for shares and give details on SMB trouble shooting.

I personally prefer SMB since it’s easy and less trouble in the long run and works with Infuse Library where DLNA won’t. My set up seems to prefer the SMB “Legacy” setting but yours may vary. SMB 3 can cause speed issues since it’s got more security involved so it may be slower. SMB 2 is faster since it doesn’t have the extra overhead of the security found in 3.

Wow, those SMB settings are something!
Thanks for pointing that out.

It seems everything now is working and I’m able to stream from my macmini to the ATV without buffering.

But… I don’t have airplay anymore. The ATV is on another network (the one between it and the macmini) and my wifi connects iphone can’t connect to ti anymore.

Any idea about how to solve this?

I could connect both the macmini and the ATV to the wifi router. That would impact the quality of the connection between the 2? I wouldn’t like to get back to “bad buffering” world.

Thanks again,

Glad you’re streaming again without the pauses.

I’m not sure I understand what you mean by “I could connect both the macmini and the ATV to the wifi router.” aren’t they connected now? By connect, do you mean via WiFi or Ethernet cables? I’m not sure why your airplay went away. I have 4 ATVs and one is connected via ethernet, 2 are on my 2.4G net and the last is on the 5G net and I can airplay to all of them from either the 2.4 or the 5gig network.

Your router might be blocking multicast DNS between Wi-Fi and Ethernet. Shitty netgear routers are notorious for doing this; especially the orbi ones. You might need to enable IGMP proxy on your router.

Actually the ATV is connect to the macmini via Ethernet but the macmini is connected to the network via wifi. And now “remote control” via the iphone or homekit controls are not available.

That’s why I was asking if, maybe, connecting both the ATV and the macmini to the router would work.


Yes. You should never connect two machines together via Ethernet.

If you want to stream 4K the Mac mini should be connected to the router via Ethernet and the AppleTV should also be connected to the router via Ethernet.

Usually your internet source comes in to a WiFi router that has multiple Ethernet ports on it.

For example, if you have cable internet, they usually have a WiFi router that has a cable jack on it as well as several Ethernet jacks. This unit also provides your WiFi for your home.

The Ideal set up would be to have both your Mac Mini and your ATV connected to that router via Ethernet each using their own cable. Then you can use the WiFi to connect to what ever iOS devices you have and then you should have airplay available to everything.

If you can’t run Ethernet cables to those two then you may have to ensure that you have all of your WiFi connections on the same band. Many WiFi routers have both 2.4Ghz and 5Ghz bands and some even have multiples of those so as long as you stick to one band you should be good. If you get a good wireless signal on the 5Ghz band for everything that is preferable since theoretically, that gives you faster speeds. Real world is often different though so don’t worry if you have to use the 2.4Ghz band since that one usually has better range and better signal stability.

It’s all a “best for you” thing that you have to try out and determine what works best for your particular setting.