Apple TV 4K Infuse Pro 6.4 Zoom "Crop" / Aspect Ratio changes not taking effect

Hi, I just discovered the Zoom “crop” and Aspect Ratio features last night under the video settings. I’m so used to double tapping on the Apple TV 4K Remote I just thought zoom was not an option with Infuse. Anyway, I successfully used Zoom “crop” to remove the black bars on a movie last night. Then on to a second movie and it did not work. I tried it on a third movie and it also did not work. I kept changing Zoom back to “normal” then back to “crop”. I tried multiple Aspect Ratios on both movies and nothing seems to change. The movies are The Interview and Iron Man 3, both 4K/UHD .mkv files just incase this helps anyone. I tried closing Infuse and re-opening, that did not help. I restarted my Apple TV and that still did not work. So basically Zoom “crop” worked the first time and will not work again at all. Aspect ratio will not work at all either. I’m running the latest Infuse Pro 6.4 update on an Apple TV 4K. Am I missing something? Can someone help me troubleshoot this?

Maybe the black bars are encoded into the movie, mediainfo should tell you the picture dimension info.

Is mediainfo an app? So you are saying that if the black bars are encoded into the video I should not be able to zoom or change the aspect ratio at all in the video settings of Infuse?

Yeah, mediainfo is a free very commonly used app for all systems (*nix, Mac, Windows) that gives you info about aspect ratio, width, depth, etc. So, if a movie says it’s 1920x1080, there is no scaling to be done for example. When I encode movies, I always crop the black bars off. So, for example, Star Trek 5 which I recently processed from my Blu Ray collection comes out to 1910x796, or, an aspect ratio of 2.40:1

If I try to crop or stretch a TV recording, it won’t as it already fills the screen. If I try the same on my properly encoded Star Trek movie, then, it works fine.

The zoom modes work in conjunction with the aspect ratio options, and allow you to crop out black bars that are embedded within the actual video.

To use these together, simply select Crop (or Stretch if you prefer) and then choose the aspect ratio that most closely matches the video. If you prefer to crop out some of the black bars but not all, you can select a less-wide aspect ratio.

1 Like

Hi James, I am watching Iron Man 3 right now, Zoom mode “crop” selected, Aspect Ratio was on “auto”, I changed it to 1.85.1 and it did not do anything. When I select 2.35.1 the black bars become very thin and when I select 2.40.1 they go completely away. Normally I would think 1.85.1 would be almost full screen with thin black bars. The aspect ratio seems to be working opposite? Or am I selecting the aspect ratio of the movie not what I want it to be?

Yes, that is correct. When choosing an aspect ratio you want to select the aspect ratio that most closely matches the movie being played, and not the aspect ratio of the screen.

1 Like

Yes, you can’t simply use the zoom mode, unless, it is properly encoded to have the correct aspect ratio without the black bars. That’s what I was trying to say. If it was encoding with the black bars and is 1.85:1, then, zooming (by itself) does nothing as there is nothing to do. That’s why I always crop it, it simplifies things. You only have to use zoom mode if desired then.

That’s why some movies may work fine with zooming, and others not was my point.

Yeah just zoom at “crop” by itself did not work with aspect ratio set at “auto” so I wonder if that means the movie was not properly encoded.

The only way to know is to get the media specs, easiest way is to download mediainfo if you want or need to know. Infuse doesn’t currently show the media specs. I am just saying I think you will find it is encoded as I stated. It’s not necessarily “wrong”. I would never do it myself though. I say that, but I had to on one movie. I think it was Star Trek Beyond on Blu Ray? It has a variable aspect ratio, as some was done on Imax specs, and some regular specs. So, the film alternates aspect ratio and I had to include the black bars for that reason. It’s the only movie I’ve seen like it. So, there are black bars for the non Imax sections, and no black bars on the Imax section.