Apple TV 4K HEVC Buffering

Do you have the beta and the release versions of Infuse loaded at the same time?

I’ve had VERY little buffering if any coming from my Unraid dedicated server, but I did watch Ready Player One the other night x265 4K and it was buffering quite a bit towards the end.

I´m afraid i´m also experiencing this annoying buffering.

Never happened to me before, running 300mpbs and CAT6 cables, NFS protocol, Infuse Pro 5.7.5 (2154), Synology server, worked like a charm until recently.

No hardware change, speedtest is fine.

My BD player works fine, however Infuse does not.

Which network protocol are you guys using? Any SMB version or NFS? As I wrote previously, NFS is a lot better/faster than SMB and it’s natively supported by Infuse. Just use the freeware app “NFS Manager” (compatible with High Sierra) and you’re all set. It’s also possible to configure NFS via your Mac’s Terminal, but that’s an annoying and tedious process. With NFS Manager, you’re good to go in minutes.

Been using NFS since day one :frowning:

I remember i had some buffering issues with Blade Runner 2049 (once i removed the bigger HD track they were solved), but that was like some months ago, and that was actually it.

Have tried some modest 30gb-45gb files now, Boss Baby and Life Of Pi, and i get buffering ramdomly, here and there, no clear reason on why it is happening.

I saw this in another thread where things had gone south recently. Seems that Synology may have recently released an update that requires a bit of after tuning.

You may want to try restarting your ATV as well as your router too.

I’m also getting buffering randomly since a few weeks. I have all my content in a NAS connected using NFS (transfer speeds of more than 70 MB/s) and in google drive. I have a very stable 1000/300 fiber connection so that’s not the problem.

The same movies that now have this problem were fine a few weeks ago. All of them are 4K HDR films played in 4K and 1080p TVs.

Since this thread is over 8 months old with a few rev levels of Infuse since it started and over 180 posts have you tried any of the possible solutions discussed throughout the thread and if so, which ones so we can try to help narrow down the issue.

Sorry, I forgot to tell I’ve tried every solution, but as I almost only use Google Drive nowadays most of them did not apply to my problem.

It only happens since ios 11.4 (or 11.4.1, I don’t remember) and the last infuse update. If I try to play the same movie using kodi everything works fine. I’ll try changing my ethernet cable but as it works fine with kodi I don’t think that’s the problem.

hi all, just bought a Samsung UHD TV and ATV4K, but I can get my BDMV files to play without buffering every 2 mins. I the ATV is connected to the withc with 5e cables, as well as my Seagate Central, both are Gigabit capable, reading this threat seems I need to try NSF as suppose to SMB, but I do no get the NSF option in the Infuse conf. menu. Is this something I need to configure from my windows PC? (i.e. managing the share from windows file explorer, windows options)
thanks.

Have you tried the different versions of SMB including the “Legacy” setting?

@J_Cortes:
Well, if your media server (whatever machine that is) supports shares via NFS (which for example all Apple machines do), then those NFS shares should turn up automatically in the “Shares” section of Infuse on your ATV, next to the SMB shares. To configure NFS shares and their permissions on a Mac, you can use the freeware app “NFS Manager” (just google it). Like I previously wrote, it actually IS possible to configure NFS via the Mac Terminal app, but it’s much easier and faster with NFS Manager.
I don’t know if Windows PCs support NFS at all.

Best

My server is Seagate Central, it supports NFS, and last night I was about to begin trouble shooting (i.e. selecting Legacy SMB too, etc) decided to try the same (and only 4k HDR) movie before I move any setting, and boom… the movie went like smoothly, I´m really puzzled by this, the other thing I remember from when the problem presented (buffering every other 2 mins, or more often) was that the ATV 4K was quite hot, not sure this is an indication that this 4k files are pushing the processor/RAM to the limit. any thoughts?
Julio.

hi, I wanted to report on how this working for me. the SMB Auto setting was working intermittently, some times it would play just fine, other I get buffering every other minute, I selected Legacy and now works just fine. Hope this helps.

Hi, I just would like to share my experiences.
SMB share just does not work well, even set to SMB legacy mode.
NFS network works (My NAS is Synology DS216play, and Apple TV 4K connects to NAS through 5G WIFI link), and settings for Synology NAS are:
a) control panel → File Services → NFS → Enable NFS, Enable NFSv4.1 support, and Advanced Settings → Read/Write packet size: both set to 32KB
b) control panel → Network → Traffic Control → Create → Select “Mac/Linux file sever (NFS)”, and set Guaranteed Bandwidth to 20480, Maximum Bandwidth to 0, OK → Enable the item and press “Save”

Then restart the NAS.

This worked for me. I can now play 4K HDR REMUX files with ease! Just had to disable SMB and enable NFS on my Synology. Thanks so much!

Still have this problem with 5.8.0 and SMB. Tried haneWIN NFS server, but movies would never start playing (spinning wheel) and metadata wouldn’t complete downloading. Speed tests show that each of my wireless links to the main router get at least 300 Mbps (to internet)so bandwidth shouldn’t be an issue.

Eventually, I spun up Server 2016 and setup the NFS server role; BDMVs load within 6 spins of the wheel now, while using SMB they took 10-15 and would buffer every 3-5 minutes. This 3-5 minutes seems to be a recurring theme in this thread.

A Windows user shouldn’t have to go through such extreme measures. I hope you guys work out what’s wrong with your SMB implementation because I’d really like to keep the app, it integrates well with tvOS, and, with a few more advanced controls to customize the Library (i’ve read some suggestions in the forums) it’ll easily make the Apple TV the device of choice for NAS streamers.

A disclaimer should be posted. Instead of “4k HEVC BDMV supported” a footnote should be added that it is “not fully working with SMB at this time.”

Ticket Number: 105703
Bug Report Code: NPQWV

Thanks so much, this fixed all my buffering issues. So much better than using SMB

@rootMBX:
As said a couple of times in this thread - forget WiFi connections when dealing with 4K streaming. Even if you get your connection to work eventually, it is and always will be way too fragile to be reliable. believe me, I’ve been there. WiFi and 4K just don’t go together. It’s not only about max. possible bitrates, it’s also about latencies and sustaining a strong connection. WiFi can’t offer this as needed.
Change to cabling your gear (min for Gigabit connections is CAT5.e) and you’ll see how stable a streaming connection can be. That will most likely solve all your problems.

That’s not really true. With a good router and a strong 5g signal you can stream 4K no problem. I do it constantly at home. 2 ms of latency, almost 300 mbps sustained. You just need good hardware.