Apple TV 4K HEVC Buffering

Recently downloaded a couple of 4K video files (Arrival and Star Trek Beyond, both HEVC) to stream with Infuse’s 5.6 update with HDR playback. Colors and picture looks great, but even with 106.7 MB down, 12.72 up internet speeds, I’m getting buffering issues playing back the data.

Apple recommends at least a 25MB/S speed to stream Netflix which works fine on my the ATV4K, so I’m not sure where the problem is arising. Everything is being pulled off of a Synology NAS DS916+ which should be more than capable of handling the 4K demand. Wondering if this is a hardware or software issue and if other users were experiencing this as well.

Are you streaming via Wi-Fi or Ethernet?

When streaming from a local source like a Synology NAS, your internet speed won’t play much of a factor, but the connection between your NAS/router/Apple TV will most definitely come into play.

We recommend using Gigabit ethernet when streaming 4K videos.

1 Like

The apple tv is connected via wifi- sounds like this might be a hardware issue if more people aren’t reporting similar issues

I’d give Ethernet a try and see if things improve.

FWIW, all 4K HEVC is not created equal. Apple’s videos top out around 30mpbs, but full 4K Blu-rays will peak around 130mbps. Other 4K content usually falls somewhere in between.

Me too same problem with 4k hdr files i’m getting buffering every 2-3 min. My apple tv 4k is wired at 1 gig and already try with wifi same thing.
When i Stream to my oppo udp-203 no problem it play fine no buffering.

I’ve a related question: When I try to play a 4K mkv file (bitrate about 50-70mb/s) on a Apple TV (not 4k, the older one!) it is stuttering a lot. Is this because the last generation is not powerful enough to display the mkv? Would the 4K apple tv handle the job of transcoding a 4k movie to 1080p?

Background: I have a 4K apple tv in the livingroom connected to a 4k tv and a non-4k apple tv in the bedroom connected to a 1080p tv. I don’t want to have two versions of the same movie on my NAS (that would also mess up the infuse library).

Unfortunately the ATV4 isn’t quite powerful enough to support most 4K videos.

The ATV4K includes HW support for HEVC, which means it will play just about any 4K video you can find. An ATV4K can be used to play 4K content on a 4K or 1080p TV.

Apple TV 4K in the bedroom it is. Always good to have a plausible reason for an upgrade :wink:

What makes you say this? I’ve been trying to find the exact specs that the ATV4K supports, and only this showed up:

  • H.264/HEVC SDR video up to 2160p, 60 fps, Main/Main 10 profile
  • HEVC Dolby Vision (Profile 5)/HDR10 (Main 10 profile) up to 2160p

But this page has more, although I’m not sure it applies to non-online streaming scenarios:

  • Profile, Level, and Tier for HEVC MUST be less than or equal to Main10 Profile, Level 5.0, High Tier.

Level 5.0 support would exclude pretty much every UHD disc out there, which are Level 5.1. This would also explain why my ATV4K wouldn’t play my backup copy of Mad Max: Fury Road, which was authored at Level 5.1.

Have you guys run any tests with Level 5.1 titles?

Historically, Apple has underreported what their hardware is capable of. We have tested Level 5.1 videos here (see attached), and they actually play very well. Not sure yet what is going on with the sample you sent in, but we’re going to take a deeper look and see if we can track down the issue.

FYI, the upcoming 5.6.1 update (currently in review at Apple) will add support for 4K UHD BDMV/ISO files. :slight_smile:

That’s awesome!

The sample was authored with mkvmerge 17.0, and includes two Atmos streams. Perhaps this is throwing off Infuse’s demuxer.

Hard to say as we haven’t had a chance to take a peek yet (beyond just replicating the issue), but having a sample helps immensely in tracking down issues like these.

PS - If you feel like doing some stress testing on your end, you can grab reference files from IIRC, the 200mbs L5.2 file plays, but is right at the limit of what the ATV4K can handle.

The 200mbps Jellyfish plays quite smooth on my ATV4K, but every 3-5 seconds I get a spinner. Is this Infuse’s buffering? (My network is 1gbps CAT6 over 2 prosumer switches, I can easily hit > 100MBytes continuous SMB transfer speed.)

Are you using an open-source lib for demultiplexing? If yes, libavformat and similar have very small default buffer settings, it’s possible that you’re starving the demuxer.

Hello James

I still get buffering with the last update 5.6.1 every 3-4 sec they are a spinning Wheel and its unwatchable. I have my apple tv 4k on my oled b6 and a apple tv 4k on my Samsung 1080p when i play 4k hdr movie on the Samsung (not hdr) i get no buffering play smoothly but when i play the same file on my oled b6 hdr the buffering start.
Both apple tv 4k are wifi my 4k hdr are mkv muxed with mkvtoolnix at level 5.1.
If i Stream my movies to my oppo udp-203 no problem.

I also have buffering problems. I have both my Apple TV 4K and my iMac connected to 1Gb ethernet on my TimeCapsule and when I try to stream a 4K movie I get constantly a spinning wheel; it is impossible to watch! The movie is located on an SSD hooked up to my Thunderbolt 3 port and provides >500MB/s read. I am using the latest Infuse pro 5 version.

Try setting it up as an NFS Share on your iMac and see if you have the same problems (I’m guessing you’re using SMB). You can use the following to creat an NFS share:

No, I am using sftp (port 22) to my iMac. I am seeing constantly Ethernet drops on iStat pro view. I tried using wireless on my Apple TV side and at first it looked fine; iStat showed a nice constant high load (I left my iMac on Ethernet) but suddenly it showed a constant low speed which resulted in buffering again (spinning wheel)! Even tried different cables. I seem to have the same issues with 1080p movies as well. I see sometimes 3.5MB/s up to 5.2MB/s and suddenly drops to 0-1KB/s!

Weird. Have you tried something else besides the Apple TV in the same location (like a laptop/MacBook) and using iperf to test over a period of time? Do you have WiFi off on your iMac or at least made sure Ethernet is higher priority in the network settings? Still seems weird it’s dropping like that if the cache isn’t built up significantly, though.

I’m getting buffering even with 1080p movies. Granted they are large files (20-40gb). This is only with Infuse. I can play 4K HDR files without any problems through iTunes.

Perhaps SMB3 support will help improve things. Just overall experience is way slower than what i’m used to. 10sec skip is nearly useless.

I am quite disappointed since I have now payed for both version 4 and version 5. Both seem to experience this buffering issues with large files. My network does not seem to be the issue; I am now making a full backup to my TimeCapsule and can see a constant flow of network traffic around 30MB/s but certainly no sudden drops to around a couple of KB/s.