Apple TV 4K - HDR only with 8bit?


I just realized that I only get 8bit output with HDR files on the ATV. When I start playback, the ATV switches to 4:2:2 and 8bit. There‘s no way to get 10bit output.

What am I doing wrong? Is this a limitation of the Apple TV?

Rather disappointing.


What TV/Receiver are you using? It’s probably not the Apple TV, but could be something in your chain.

It is connected to a Pioneer SC-LX901. The ATV is the only device hooked up to the Pio that is showing the 8bit limitation with HDR.
An Oppo 203 and a Zappiti 4K HDR are doing 10 and 12bit just fine.

This should be resolved in the upcoming 5.6.8 update.

Hi James! The video output information for 4h HDR is still shown as 8bit 4.2.2. The video output information of movies purchased on itunes are also shown in 8bit 4.2.2. is tvOS 12 or Apple TV 4k problem

Check to ensure you have Match Content enabled.

IIRC, these settings get reset when installing tvOS betas.

This connected all, in fact puts in the information of reproduction HDR BT2020, 8 bit 4.2.2

If it’s affecting iTunes movies as well, I imagine it has something to do with one of the devices in your pipeline. Perhaps the Apple TV is detecting your TV doesn’t support 10bit and is adjusting the output accordingly.

Infuse can only switch to modes that the Apple TV has verified will work.

If you are reading this off your AVR info display, then it is wrong. AVRs can’t detect the actual color bit depth of 4:2:2 signal because 4:2:2 pixel encoding doesn’t use the CD bits in HDMI GCP to indicate Deep Color mode (> 8-bits).

I have it connected through a Onkyo TX nr656. The information I look through the projector Optoma uhd51. With Apple, files UHD remux, samples 4.2.2 8 bit BT2020HDR. With the Xbox One X player the information comes out 4.2.0 12 bit bt2020.


for a few weeks I have 8bit output again, and I have do not this problem with my Zidoo or my Egreat

with all modes (4.4.4 under 30 Hz and 4.2.0 above 30 Hz) i have only 8Bit, I think it comes from an update of the ATV4K

see you

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.