Apple TV 4K deleting files on server


I am running Infuse Pro (current version) on my new AppleTV 4K
Well - if I just stop a film during the news - come back to it and try to continue the film - Infuse tellers me that it‘s havin issues
Well if I check my MacBook - that I do use as a server - the file that used to play is empty - 0kb.
I need to copy it into my share folder again - and not take break to watch it.

If I do not just stop it - but go one level up (that s where the meta data and a picture is shown) everything is fine.

Well - how can I stop Infuse or AppleTV from deleting files from my server?

This is related to a bug in macOS 10.13, as discussed here Mkv file goes to zero bytes

In short, we’ve not be able to replicate it here, but some users have said updating to 10.13.1 resolves the issue. Additionally, it seems likely 10.13.2 will be available on Monday, and I would recommend updating to that as soon as possible once it becomes available.

Thank James,
I m already running 10.13.1 - and it as it again happened today…

Well I ll update on Monday and ll come back to you if it still prevails…


Hi James

You say ‘This is related to a bug in macOS 10.13’. If this is truly the case, why is it that this 0kb problem occurs only when using Infuse and NOT while accessing files with any other player or software ?

I am so tired of losing files while using Infuse. However because I hate all other players available, I am continuing to use Infuse. I am now taking a back-up of a file before I start playing it using Infuse. This is annoying to say the least. Is this what I my user experience with Infuse is doomed to be going forward ?

The reason we believe it’s a macOS bug is that it happens even when read-only access is enabled in macOS.

Read-only access prevents changes from being made to files by other apps (IE they can read, but not write, delete, etc…). Even if Infuse had a bug where it was causing files to be deleted, having read-only access enabled would prevent this from becoming an issue. So, this is either a bug in macOS which is causing files to be corrupted in certain cases, or there is a massive security hole where apps like Infuse can modify files even when files are set to read-only.

We’ve put some effort into replicating this here, but we have not had any luck so far. We are hopeful the upcoming 10.13.2 update may help with those who have reported issues. If 10.13.2 doesn’t resolve what’s going on, we’ll need to start gathering more info to see if we can narrow down a common environmental issue that may be leading to this behavior.

We expected to see 10.13.2 released on Monday (as Apple has been pushing iOS, tvOS, and macOS updates all on the same day as of late) but it seems they may have delayed it for a few days. Hopefully it’s not too far off.

Well James!
This is most annoying - and that Apple would come out with a new update - is what you already said last week…

It looks like macOS 10.13.2 was just released today.

Please try updating and let us know if the issue persists.

Nope - no update today…
Been checking daily anyways…

It’s just started rolling out, so it may take a bit to appear in your part of the world. :wink:

Hi James

BAD NEWS I AM AFRAID !! I upgraded my server OS to High Sierra Ver 10.13.2 but nothing changed. I rebooted my AppleTV4K, my network switch etc…and then played an TV Episode MKV file. 5 minutes into the the episode, I paused it for about 5 minutes. After that, I quit the file AND then tried to play it back - ONLY to find that the file wouldnt play BECAUSE it had been reduced to a 0K file :-(((

What do we do now ?

Hmm, can you send in a report from your Apple TV (Troubleshooting and Getting Support – Firecore) and let us know the title of the video you were playing when this happened?


I am not sure why the name of the file I was playing is relevant. It was an episode of a popular TV series. After I made the post in this forum, I tried the same process (Play File, Pause File for around 5 mins, Quit File, Play File Again) 6 times with different files (all mkv) and 5 out off the 6 times all the files were reduced to 0K.

This is so frustrating :frowning:

I just tried the same process of playing files from infuse on my iPad - absolutely fine and no 0K issue. So looks like whatever is happening is only between the AppleTV version of Infuse and macOS High Sierra (including version 10.13.2.

I would say that would be the most relavant part of the log lol

They need the name of the video file you were watching when the problem occurred so when they look at the content of the log file they can find the entries relating to the file which is having the problem.

This is correct.

Being able to reference the file played in the log would allow us to see what’s happening in Infuse when the issue occurred.

Hi James

I apologize for the delayed response. I am traveling today and will get back home tomorrow. Once I get back I will simulate the problem once more and send you a log from my AppleTV as well as send you an email with the name of the file I was playing when the problem occurred.

Thank you for your patience.

Sounds good. Thanks!

This is why you dont use a MAC as a server …

More accurately, this is why you don’t use a MAC running High Sierra as a server … (for now).

This is a non issue on previous Mac os’s as far as I’ve seen.