Apple TV 4k 2021 not playing h265 files correctly

I recently upgraded to the latest Apple TV 4K with the thick gray remote, and ran into an issue streaming many of my MKV files with Infuse. H264 files and raw 4K files stream fine. Files that I encoded as H265 are no longer playing correctly. It appears in a way similar how a video player that doesn’t have MKV H265 file support plays these files. Everything is neon pink, green, blue with a metallic look.

  • On all immediate previous models of Apple TVs using Infuse and plex, these files play normally. Only the newest one has this problem.
  • Plex does play the files correctly on the newest Apple TV. Only Infuse is doing this.

Apple TV Details:
Format: 4K HDR. 60 (59.94Hz)
Chroma: 4:2:2
Match Content: Range & Frame Rate
tvOS 15.4 (same on 15.1)
Infuse Pro 7.3.7 (4056)

First, have you tried a restart on the new ATV? Have you tried a fresh install of Infuse?

Maybe do he video test in the ATV settings to make sure that everything is plugged in tight and the cables aren’t maybe not seated on one end or the other?

Thank you for the suggestions. Sadly no difference.

  • HDMI check looks good
  • Restarted and ReInstalled both Infuse and the entire Apple TV OS
  • All is plugged in tight.
  • Plex app on the same device is able to play the files correctly. Just not Infuse.

Would you be able to upload one of these problematic files so we could review it here?

Uploaded a 5 min segment of the file. This occurs to every file I have encoded this way and isn’t isolated to a file or a few files.

  • HEVC/H.265/MPEG-H (12-bit)
  • AC-3 Audio, has subtitles and chapters

This issue is still occurring. Only occurs on Gen 5 of Apple TV. Gen 4 still works perfect. I also noticed a weird behavior on Plex on the Gen 5 device where shading showed lines instead of a gradient image.

Does Infuse rely on native codecs? And could those codecs be problematic on my specific device?