Apple TV 4.3

Hi,

Good day,

Ive read several threads, specifically started by tillk.1608, before posting my own. I done exactly what I was doing in the past:
1. Saved my SHSH Blobs thru Ifaith (windows pc) - 5.8kb
2. JB my ATV 4.3 thru MAC
- SP 9.3
- Latest Itunes

At the end the of the JB process, I get this message “Your Apple TV has been restored to factory settings. Please disconnect your Apple TV from your computer and reconnect it to your TV.”

But when I hooked it on my TV, I only get the itunes logo plus the usb cable the led is blinking continously.

Thus, I tried the DMG stitch using TC on my windows pc. Unfortunately, I get the same result.

However, when I jb the unit with the tethered 5.3 it runs smoothly. I hope you can help me and point out if Im doing something wrong. Just want to make thru a untethered 4.3.

Thank you in advance.

Sounds like you are doing everything correctly, Marlon.  

I’m kind of O/C, so I take the extra step to first use the PC version of Seasonpass 9.3 to save the signatures.  I then use iFaith to confirm that the signatures HAVE been saved on the Cydia server – which they always are if you successfully save with Seasonpass.

I then feel comfortable “mucking around” knowing that a revert is assured.

Since your signatures are saved I would just go ahead and revert back to 4.3 again rigtht now.  And keep trying to make it work since it should.  

As I said in another post, these 4.x versions can be very finicky.  Took me over 15 attempts trying to make a 4.2.1 jailbreak work.  And when it worked, I did nothing differently then on the previous 15 attempts that failed.

Let us know when you solve this!

thank you so much for your assistance. On my first time after your post, I revert back to 4.3, and get the same result. II just have to do it whenever jb fails. By the way, do i need to delete something (like the created ipsw) or just proceed with the usual jb process until it works?

Ill be glad to post it once I successfully jb this 4.3 :slight_smile: - be included in the long list of guys, who finally jb their ATV 4.xx.

Regards

At least one of the error messages I received during my 16 attempt process (maybe error 14?) suggested that a corrupt IPSW might be at the root of the problem and recommended that the previously created IPSW be discarded.  Or you can sign into your computer under another account name which, I read, will assure a fresh IPSW.  

The point is you want a fresh “clean” IPSW created for your jailbreak.

See if that doesn’t help.

 

Weird thing about the jb process, im not get any error message. I tried signing in to a different user though same result :frowning:

So just to properly understand your situation:  You have no issues completeing a jailbreak that ends with the usually successful “restored to factory settings” message.

Yet, when you connect your TV, you only get the cord and logo icon?  

That is just too weird, Marlon.

Oh yes…thats the case. But when I upgrade to a tethered jailbreak 5.3, its working properly. Whenever, I try to jb it to 4.3, which im successfull, i only get the usb cord and logo icon plus the led is blinking fast.

Now, Im trying my luck using Snowbreeze v2.9.14 - still no luck. Im getting error -20

still no luck…it seems that i need to get the 5.3 while apple is still signing it.

Hi All,

I have two 4.3 units which are doing exactly the same as Marlon describes. I’ve tried everything and read many threads like Marlon. I am usually a PC based jailbreaker, but I even got hold of a MAC so I could see if that resolved it, but it didn’t.

If anyone has any idea’s I’d be grateful.

Which version of 4.3 are you talking about here?

My units are 8F455

My units are 8F455

  • Sorry dont know why that got posted twice!

Well, 4.3 (any one of them) can be a pig in Seas0npass. I recommend using an old version of seasonpass Version 0.3.52.4509 to build the patched IPSW and then using iFaith to build a standard, but signed IPSW).  You then use TotalCommander to move the dmg files from the patched SP IPSW into the vanilla but signed iFaith IPSW, overwriting all.  Then run iReb, iTunes using Alt + Restore and Bob is usually your uncle.  Any other way I found a monumental frustration.  My method, which I developed after a year jailbreaking these things works (nearly) every time.

 

Aplogies if you don’t have Win, I find Mac very difficult to use to jailbreak older firmwares.

I have the same 4.3 8F455. I followed carefully this procedure - unfortunately same result :frowning: I got the the message “apple restore” but when i hooked it up, i get the logo and usb cable.

On the contrary Mac is easier than PC, I have done Both PC and Mac, in PC the total commander method and in Mac seasonpass that does all the work for you, the only thing I now do in PC is save shsh in iFaith 1.52 so it uploads to ifaith server, then on Mac just seasonpass and it will do all process automatically for you.

Can’t be easier than that.

For older firmware use seasonpass 0.92

if by chance and hopefully, you jb your units - ill be glad to hear from you the procedure you followed.

Well, as it happens I am doing a 4.3 as we speak.

Hi Ian82,

Thank you for your knowledge. Did you jb it?

I use the total commander method in the main, but it doesn’t work for these two. I think the difference is that I dont think I have the blobs saved using the older versions of iFaith, so the blobs I have are downloaded form Cybia and then I’m only able to generate the signed firmware in the later versions of iFaith. The guides for total commander from memory where very specific about using iFaith 1.4.2, is that what you use Ian?

I’ve never been able to get a signed IPSW 4.3 back onto the units in order to extract the blobs with different iFaith’s.
I’m going to get hold of 0.9.2 seas0npass for the MAC and give that a whirl as I’d been using 0.9.3 since getting hold of a MAC