Apple TV 2nd gen stuck in recovery mode after jailbreak


I'm quite new to the jailbreaking scene but i read somewhere that the jailbreak for apple tv 2 was stable, so i decided to give it a shot. I went ahead and downloaded the SeasOnPass software and followed the steps described in the guide on the support page. But after everything was complete, my apple tv remained in recover mode. 

When i tried recovering my apple tv with itunes, it gave me error 11. I tried recovering with an existing ipsw file, but to no avail. My apple tv was working fine before doing this :/, how can i get it back into a working condition ?

I thought it could've been because i'm running the itunes 12 beta, but i downgraded to itunes 11 but this gave me the same error. 

Forget the instructions on the guide page… there is no need to use iTUNES at all with the latest SP tool.

Get on your MAC, download the latest version of SP, learn how to put your ATV in DFU mode when prompted, and you are good to go.

Connect your ATV to your computer… choose 5.3… wait until prompted to enter DFU mode… and then “let it go.” The program will complete on its own without ever needing iTUNES.

The Seasonpass program on a MAC works incredibly well. No need to overcomplicate things.