Apple Tv 2 with problems!

Hi everybody!!

Thanks for this forum, it’s amazing!

I have my Apple TV 2 with jail, my software is 4.3 and I had a problem when I wanted update the XBMC from Nito Tv (is installed in the Apple TV2). It didn’t work and appears this message:

E: dpkg was interrupted, you must manually run ‘dpkg --configure -a’ to correct the problem.

And I haven’t the icon of XBMC in the Apple tv2. I have “Cfbundlename” icon. I tried to recover the XBMC program with the tutorial Nito Tv that I found in xbmchub forum. Now, I can run the XBMC but I the plugins don’t work. And I haven’t the XBMC icon yet.


How can I resolve it?
Can I re-install Nito Tv from this program? Is it help me? 

I’m afraid because I don’t want to loose my jailbreak in the apple tv, and I don’t use different programs for jail since I bought the gadget.

Thank you very much for your time and your support!!

Your Sincerely, 

Ivania.

You can get a copy of “aTV Flash (black).exe” installed into your ATV box, and update your XBMC.

and don’t forget to back your firmware too.

 

Good luck.

 

Van

ssh into your apple tv using terminal on mac or putty on a pc and type “dpkg --configure -a”, this will correct the problem.

Tonight I tried to update XBMC to 12.3-0 and got the “dpkg was interrupted, you must manually run 'dpkg --configure -a and correct the problem” error. I sshed in and ran the command, which got me:

Setting up org.xbmc.xbmc-atv2 (12.2-0) ...

chown: cannot access `/Applications/XBMC.frappliance': No such file or directory

cp: cannot stat `/Applications/XBMC.frappliance/AppIcon.png': No such file or directory

 

cp: cannot stat `/Applications/XBMC.frappliance/AppIcon.png': No such file or directory

When I logged into firecore.com just now, I see my firecore license has expired. Would this be causing a problem? Thanks for any help you can provide!

The FireCore license does not expire - merely the support runs out. This does not matter unless you want to re-install ATV Flash again as the install process checks you have the latest version of the installer.

As to why the XBMC upgrade is failing I have no idea. It might be worth checking in the XBMC forums to see if this is a known issue.