Apple TV 2 with 4.3 2557 is driving me insane

After looking at my Apple TV 2 shrinkwrapped for a couple of years now, i finally cleared an afternoon to deal with what i expected to be a process with many hurdles…but the past many many hours just seemed like an excercise in madness.

at least 2 hours of research before i even started led me to download Seas0npass 0.9.2 beta with iFaith, dump my blobs, generate a Firmware from the 4.3 8F455 option in Seas0npass, got the Apple TV 2 into DFU mode (many times by now), iTunes to start up, but always get an “iTunes restore script failed!” error.

tried a manual Alt+ Restore with the patched Firmware file, but keep getting mostly 1604 errors, sometimes 1601, even 2001 and 21 (must have been through the whole process a dozen times today).

i even tracked down a Mac version of iREB, ran that (looks nothing like the Windows version, but happens inside a command prompt), had to figure out myself that it only seemed to do anything if i put the Apple TV 2 through DFU mode while in the iREB prompt, until it finally told me that it succeeded to exploit with limera1n, and to go ahead and restore in iTunes, but alas, 1604 again.

followed the instructions on yet another site that instructed me to unplug the power cable (which i hadn’t previously used during the jailbreak attempts) at exactly the half-way point of uploading the most important patch, but i keep getting 1604 errors.

wow, what a pain in arse that has been…i mean, i’m a patient person, and have jailbreaked my iOS devices since my first iPhone many years ago, but this is ridiculously hard…i really didn’t want to go to sleep today without having had success with this investment of 6-8hrs of my time, but at this point it looks like i might have to.

could anyone give me another spark of hope that this is even possible? other appear to have been successful.
i mean, isn’t there an easier way to jailbreak an Apple TV 2? i know Seas0npass is a great tool when it works, and couldn’t be easier, when it works, but since i seem to have tried everything, i wonder whether maybe pwnagetool or one of the other jailbreaking tools might be successful where Seas0npass isn’t?

anyone’s help would be greatly appreciated.

your tired jailbreaking soldier,
Till 

after re-reading all of the stickies once more, it occurred to me that i hadn’t plugged my Apple TV 2 into my monitor since first trying to jailbreak, and that maybe, just maybe, the 1604 was a false positive, but no such luck…as a matter of fact, my Apple TV seems to be stuck in the iTunes and USB cable graphic (Restore mode) now, and even rebooting iit won’t get me out of it…so am i also bricked now?

what to try next?

Try using Snowbreeze to manually jailbreak instead of using S/P.  Also, make sure the file size of your saved 4.3 blob is at least 6 Kb.

 

okey dokes, i’ll try that next! where do i find the actual blob file, to check its size?

do i need to do anything special in sn0breeze for it to not mess with my firmware in a non-recoverable manner? or simply load the official Apple firmwar, patch it, and restore it?

will the fact that i appear to be stuck in restore mode hiner my attempt at this now?

if the blob is the xml file inside the iFaith folder in Application Support/Seas0nPass, then it is 5,976 bytes (8 KB on disk), according to file info.

but wait, isn’t sn0wbreeze Windows only? what other tool can i use on the Mac? i just downloaded redsn0w, but since my Apple TV seems to be stuck in recovery mode, and i cannot turn it off, it won’t let me do anything.

my attempts to make Pwnagetool work have also failed so far (it claims that the 4.3 firmware is the wrong bundle, both the factory or the patched one)…where to go from here?

sorry, but i modified my post after you replied (i know, not a good thing to do)…but anyway, i am on a Mac, so most of these instructions don’t help me…iFaith and iREB also don’t seem to be anywhere near as user-friendly on a Mac as they appear to be on WIndows (not they are particularly intuitive on WIndows).

and i have 5 different USB cables here, all of which have never failed me before, and all of which i have tried.

so since i can’t use sn0wbreeze on the Mac, and the USB cables are also unlikely to be the culprit, what else to try?

Oh sorry I didn’t realize you weren’t using Windows.  MaxieWagner is better versed than I am using a MAC.  Perhaps he will chime in.

I hope he does, as i am definitely stuck in recovery mode with no place to go, at the moment…better get some sleep and see what a new day will bring.

thanks for trying!

Firstly, you should save your 4.3 blob locally to your desktop using iFaith.  Then you can easily view its size.  You will likely need to use an older version of iFaith.  iFaith/iREB should get you out of restore mode or you can use T/U.  Here’s some basic info on using Snowbreeze manually…

Also, be sure your micro USB cable is functioning properly.  This can give you 160X errors.

If you can get access to a windows machine I can help you but not on a Mac.

On windows you need

iFaith 1.5.9

TotalCommander

TinyUmbrella

Snowbreeze Latest

Happy to help you if you can get that lot up and running on a windoze machine

Cheers

Sufferinsuccotash and Ian82 are truly knowledgable on PC solutions.  And while I know you’re frustrated at having spent so many hours without success on your MAC, I’m afraid you may need to try this on a PC to get this done.  

However, can you first confirm that you are absolutely running the latest version of iTunes?  Version 11.1.1 is the most recent – and farily new.  I kind of hope you are not since that might be a very simple solution to your restore errors.  

And since you have saved your blobs (something I could never do on my MAC version of SP 9.3), you should definitely try downloading 4.3 (8F455) with your MAC version of SP 9.3.  In combination with the latest version of iTunes, you might be surprised that iTunes will successfully complete without the need for another computer.  You SHOULD have success here since I did it successfully just last night when I got the dreaded “conflict error” when using SP 9.3 to jailbreak a 4.3 – on my PC!  

Failing that you’ll need to get access to a PC.  The easiest solution at that point would be to just use SP 9.3 to create the IPSW by selecting 4.3 (8F455).  When iTunes opens, hit the shift key, click restore,  and select the 4.3 Restore IPSW inside My Documents.

If that should fail, either of those two other gentlemen could direct you on some of the other PC tools that are useful.  

I know this wasn’t the answer you hoped for but, in the worst case, with just a little bit of PC time you should have a sweet new jailbroken ATV 4.3.

 

 

 

3 things are need to jb 4.3

 

  1. saved local bloobs

  2. ifaith

  3. snowbreeze

 

if you don’t have all three give it up and try jailbreaking it with 5.3 if apple is still signing it.

 

note: you can use the total commander method mention but you need the blobs and it’s more complicated

Yep, Snowbreeze sometimes works on its own… Once you have the blobs of course…

Hi, I have done a lot of this 4.3 and had the issues you have now. the problem you are having may be that the created custom ipsw is bad, happened to me several times and after creating a new one it worked. Also if you have boot camp in your mac you can do it from there too

Easiest way i found was:

 

you need a PC only to upload shsh to ifaith server i think Mac version saves only locally and sometimes when extracting they get corrupted.

1.-iFaith version 1.52 on PC save shsh and then verify it. the rest of the process you can do it in your Mac.

2.-On your Mac seasonPass, right click the create ipsw a menu will pop up from there select your firmware and the rest of the process is automatically, you will only need to enter dfu mode when seasonpass prompt you to.

Hope this help you too cause I helped a couple of guys having same issues as you.

top o’the mornin’, lads…back in the saddle, and encouraged to see so many great morsels of advice from you seasoned Apple TV ja warriors!

well, sounds to me that having a Windoze machine to experiment with would be one of the better chances i’d have, so i just un-packed my little ASUS netbook (running Windows 7) and will collect all the tools recommended to me by ian82.

MaxieWagner, i am running iTunes 11.1.1…and as for the blobs, i had to track down and use Seas0nPass 0.9.2beta to have the option to dump my blobs, and i hope that the file called “00000332B905D54F_4.3 (8F455).xml” inside of Library/Application Support/Seas0nPass/iFaith (see attached, i had to add .txt to allow for it to be attached) is the one i need to save my ass if i mess up…but i could not tell whether it was also uploaded to an outside server, or just saved locally.

Chevy45, as for your concern that maybe the patched IPSW may be faulty, i did generate it multiple times in my attempts, and even used two machines (a Retina MBP and an i7 iMac), so i am reluctant to think that it was faulty 2 or 3 times in a row…but weirder things have happened.

Well, i’ll try to get my little ASUS netbook up and running with the suggested tools and will report back once i have done so, then await further instructions…if i can get this worked out today, inshallah, then the pain of yesterday will be quickly forgotten…here’s to hoping!

thanks again, everyone for bearing with me!

 

I do think you should try the easiest solution first and try downloading the appropriate 4.3 IPSW on your MAC as was recommended.  As Chevy45 said, this is a 4.3 process that often starts with saving the blobs on your PC and then finishing the job with SP 9.3 on your MAC.

You indicated that you saved your blobs, so you should be able to just finish with your MAC.  However, if you have a PC handy, you can insure that your signatures are saved with iFAITH.  You can also check to see that your SHSH cache were properly saved on the Cydia server with your SP 9.2 effort.  I can verify that the windows version of SP 9.3 WILL save the signatures on the Cydia server.  

Good luck!

well, i downloaded and installed iFaith, iREB, sn0wbreeze on my ASUS Netbook, dumped my blobs with iFaith, got the signed firmware from Apple, ran it through sn0wbreeze in “simple” mode, shift selected it in iTunes and got a 3194 error upon restore…pfffff.

what next?

Try the Mac IPSW download.  You have saved Blobs so it’s definitely worth the effort.

what exactly do you mean by trying the MAC IPSW download?

sorry, i missed your previous post…so, back to the Mac and Seas0onPass for the next try.