Apple TV 2 keeps crashing/boot loop.

I honestly have no idea what on earth is happening. It’s extremely weird because I can still SSH to it…but it keeps turning on and off on my TV like the menu pops up for a second and goes black. Sometimes it lets me use the remote to switch menus for like an extra second longer before rebooting again. It’s 4.4.4 jailbroken and this all happened right after I rebooted (didn’t install anything funky). It was literally working perfectly fine and then this happens when I reboot it, never any problems before.


The second weirdest thing is how it does this, but stops when I turn off all the routers or just anything it can connect to as wifi…ditto if I plug in ethernet it does this, if I plug it out it boots up fine and I can use it normally with no problems.

So? Is there any help or directions someone may give me to get started to see what’s wrong with it? Because I tried googling and it’s a weirdly worded problem but I found other people that had the same issues, but their posts were back in the days when Apple was still signing the firmware in which they could just simply restore and everything would be fine, and stuff and for some ungodly reason it can’t find any SSH and obviously if I boot it up without connecting to any network I can’t find any SSH of it either… so yes restoring does not work and as of right now I’m not going to update/restore to 5.x+ anytime soon.

So basically it seems to be some random issue with networking and seeing as how I still have SSH working surprisingly, can someone tell me where I should look? What I can delete or add? Please :frowning: every help would be appreciated! 

Are you by any chance using a 3rd party DNS like HideMyAss to proxy into a different country to get NetFlix working for instance? 3rd party DNS setups are known to cause an issue.

Um I’m in America and I don’t use Netflix, or any proxy’s or network doohickies for anything…Anything thanks anyway, I finally got it to restore but I just decided to update to 5.0 with tethered anyway, I’l live I guess.

Based on an untethered jailbreak for 5.1.1 should, unless something changes, be available this week.

I’ve had the exact same problem several times. The only solution was to do a full restore/jailbreak with season pass.

At least one of the times the problem started, I was only using the youtube app when it rebooted. Since this was just one of the standard apps, it made me suspicious that the problem might be caused by the aTV2 running low of local storage. The last time that it crashed I only had nitoTV, Media Player, and Couch Surfer installed. On the next restore I only installed Media Player, but this time disabled Metadata fetching. So far in the 3 - 4 weeks since the last restore, it hasn’t missed a beat.

You are right, it is a memory management problem. I have opened ticket about these reboot loops a month ago, and suggested to support service that it is related to the atv2 running low on memory. But, up to now no news about the solution.

I was able to fix my reboot loop by adding to /etc/hosts


After blocking that hostname my atv stopped crashing every second or so.


Wow thank you kate this proved to fix my problem;

For Basic user: 

SSh to atv:



ssh root@youratvipaddress



echo "" >> /etc/hosts

Unplug and reboot or do

killall AppleTV

Thank again Kate for posting!

How to undo it?


Same problem for me. I did the fix:

echo “” >> /etc/hosts

but now I have lost all the iTunes store icons on the ATV like Movies etc… 

How do we undo this or get the icons back?


grep -v ax.init /etc/hosts > x

mv x /etc/hosts

Is this problem caused by using the new iOS Remote (3.0) app? I have this same problem but I narrowed it down to a problem with the new app, as have the people in this thread:

Is anyone here not using the new app and having this rebooting problem? 

Apparently this problem is related to iOS Remote 3, communicating with a jailbroken ATV2 with iTunes Match enabled.

Check this out:

I am a little new at this so where do I put these commands. Do I run this in a  Terminal Window?  

grep -v ax.init /etc/hosts > x

mv x /etc/hosts


Match appears to be the wrench in the works.  Turned off itunes match on my jailbroken 4.4.4 at2 and suddenly using my latest version remote app and atv2 no longer causes a reboot every time I touch a button.

I’m having the same Restart Loop problem after updating Couch Surfer Pro.  Restarts when I push Bookmarks or History buttons.  I’ve signed out of iTunes completely and have used both a Remote app device and a regular remote device…AND STILL JUST RESTARTS.  HELP!!!

The mentioned Terminal commands didn’t help either.  Still have that Restart Loop.

That particular behavior happened to me with the boot directly to XBMC addon installed … Disappeared afterwards.

I’m still stuck in the loop and don’t want to restore until a new jailbreak is released.

I have tried SSH the following via Putty to no avail. Any other ideas?

echo “” >> /etc/hosts
unplugged ATV
Still boots in loop

The loop boot issue with remote seems to have disappeared with the latest update of the Remote app, at least for me. iTunes Match works fine.


Anyone can confirm this as well?