Apple TV 2 jailbroken with no picture

I’ve had my refurb Apple TV 2 for a few months and it’s been working wonderfully! Unfortunately, there was a lightning storm a few days ago and there was a power surge. My ATV2 is plugged into a Cyberpower UPS surge protector, so it should have been good; however, I didn’t have any power to it when the power returned. So I unplugged it, and plugged it in again today and I get a white power light! Unfortunately, there is no picture with it. I’ve tried restoring through itunes with my signed jailbreak firmware and it says that it restores okay, but I’m still not getting a picture. Every once in a while the light will blink a few times, then it will be steady again. Any ideas for what I can do to fix it?

Unfortunaltley, your ATV is  fried!

RIP

 

 

One of mine atv2 lsogot hit by thunder, so i was upgraded to latest atv3 firmware then reverted back to 5.0.2 and having problem to get into dfu mode, i tried 3 times and plugged in the power cabel until itunes started, then it worked.

Have you tried a different HDMI port on your tv or a different HDMI cable?