Apple Tv 2 is not booting.

I had my Apple TV 2 jailbroken. But I decided I wanted to remove the jailbreak because I was personally not finding much use to it. I wanted to update to 4.3

However, everytime I would try to update to 4.3 it would say it could not update. So I tried to restore it via iTunes and it said “apple tv is not eligible for requested build.”

So, I went back into my Apple TV and tried to do an update. This time it seemed like it was doing everything great. Until it went to boot up. It has been stuck on the apple logo boot screen for quite some time now. I don’t know what to do… 

I am having this exact same problem. To expand on it, I also cannot “re-jailbreak” my Apple TV because I cannot enter DFU mode while running SeasonPass or anything else. Help would be greatly appreciated

 

Yes, I cannot enter DFU mode either. My apple tv is just a paperweight at this moment. 

Does anyone have any kind of insight or solution??

It’s been 4 days and my Apple Tv still does not work…

Had the same issue.  Plug the Apple TV into a computer with iTunes running using a USB cable.  Your device does not need to be in DFU mode.  It should be recognized in iTunes.  Simply restore everything.  iTunes will download 4.3 and install it.  Unfortunately, there is no going back, as Apple is no longer digitally signing earlier versions of the OS.

I tried. However, I kept getting a “apple tv is not eligible for requested build” every single time. 

I option-clicked restore and found another build and it still would not work. It would tell me the same thing.

 

I finally tried it again today but with a build I found in my documents folder. It was a build called AppleTV2,1_4.3_8F202_Restore.ipsw

I restored it with that via iTunes and was able to successully (and FINALLY) restore my Apple TV with no problem. Then, I just updated it later. It works perfectly now. 

Thank you for your help, though!

I had similar problem. I have Jailbroke two of my black Apple TVs. On one of them I just could not figure out how to get the XBMC add on videos to play without getting a script error. So I decided to just restore the atv and then re jailbreak it. When i did it got almost to end and I keep getting a error message 21 and 9. after trying several times with no go I just plugged in the atv pressed resore and it restored to latest version of ATV. Then when i tried to jailbreak again same thing as before. I suspect the seasonpass does not work smoothly with the latest software version of atv? I did try the persons advice of option clicking on the ipsw file that is in the document file. To bad the seasonpass manual does not explain an easier way to re-jailbreak or even why you are jailbreaking as when I came to that part I got a script error and seasonpass is looking for file. It popped up but they do not say option click on it. I hope someone can get a fix for this as I miss my streaming video shows on XBMC

Carolyn - I was able to restore mine by taking it to work and restoring it through iTunes on my computer there. I have a Mac at home and a PC at work, but there was no compatibility issues: it worked fine. One odd thing was that after restoring it successfully, I tried restoring it again, this time through my Mac…but got the same error message. It’s probably no big deal - I doubt I’ll have to plug it into iTunes again - and it is working fine now. 

I’d try using a friend’s computer to do it. Seems like that is a common solution to this problem.

So I need to Jailbreak with a PC as it will not work with a mac at this time? What about adding ATV2 Flash Black. Do I need to also launch that on a PC to it? As I am fairly new to this string, how long does it usually take Firecore themselves to update their software and work bugs out? It definatly seems like the update to Apple TV has caused a lot of these problems.

Beats me, kingego. I don’t think it’s exclusively a “restore on a PC” issue, just try another computer if you can. I was successful on the one computer I tried, which happens to be a PC. I’m guessing FireCore is pretty swift in working around the issues, but others around here would be more informative than I would be.

Thanks, ronaldo9! I was able to restore it successfully yesterday with my own mac using another build in a folder called tethered. I guess that seas0npass had made? I am not sure, there were two builds in there. I tried the first one and iTunes let me restore to that. 

Thank you for your help, though! I am glad you got yours working.

On your advise tried to Jailbreak the ATV 2 on my wifes mac and it worked fine.Went ahead and installed the flash and my video add ons are now working fine. I think when I first started to Jailbreak them (as I have 2 ATV2’s) a couple of weeks ago I had a problem and to solve it it was advised to put into trash a plug in file that was the old vitual TV file. When I did that it worked fine. Perhaps Season pass created a file that is corupting it from re-Jailbreaking the ATV after it has already been done? But then it did allow initially the other ATV 2 to be Jailbroke in begining, so who knows. I would suggest that Firecore would provide a detail manual and users guide on all their software and companion software. I would not be retrying to Jailbreak if I had more information on their menus, setups and programs. While I did find quite a bit on XBMC it still did not describe what all the button choices and settings were for and mean. Because of this I messed something up and had to just restart. Anyways thanks a lot Carolynglope & Ronaldo9 for your help.