Apple TV 2 iOS 4.3 Jailbreak failed. Getting a screen with iTunes and USB cable. No errors during the install process.

Yesterday, I got my hands on Apple TV 2 iOS 4.3 (optimal version for XBMC). I downloaded latest Seas0nPass and had latest iTunes running. Everything ran fine with no issues. However, when I plugged in my Apple TV 2 into tv all I got was iTunes logo with USB cable. Also the front light was rapidly flashing. I tried to repeat the process but got the same results. Finally I tried Tethered option but was advised that my device did not need it.   Is there anything that can be done at this point?  Thank you very much for your assistance.

run seasonpass and press ‘‘tether boot’’ and follow instructions , as you upgraded and did a jailbreak for the latest ios5.1.1.

There is no way back, sorry, you had to save shsh blobs to have it on 4.3 and make JB in another way. Now you have latest ios JB which is tethered.

 

A suggestion for fireCore:

It might be a good idea if the Create IPSW button in SeasonPass could display what version of firmware it was about to create the jailbroken IPSW for by default. This would alert users to the need to take alternative action if that was not the version of firmware that they wished to try and jailbreak so that they need to do something other than simply click that button. It would also help identify cases where the version of SeasonPass is too old to jailbreak the version(s) of firmware that are currently being signed by Apple.

Thank you for your replies.  The solution provided worked.  I completely agree with itimpi that some warning and additional instruction would be helpful.  Thanks again.