Apple TV 2 Can't Enter DFU mode

I have tried 100 times to get the device to enter DFU mode without luck.

The Jailbreaking with Seas0nPass guide isn't perfectly clear about how to get the device in DFU mode. I mean it doesn't say anything about having to plug in the power cord to the device, perhaps it's not necessary to ever plug in the power chord to the device?

Some other guides say it's necessary.

I hold down the Play/Pause & Menu buttons at the appropriate time for 10+ seconds but it doesn't enter DFU mode.



Apple TV software version is 6.1

The software downloads the appropriate software, patches it, saves it, and gets ready to load it to the device, then shows the screen saying it's waiting for me to hold down the keys and put the device into DFU mode.


One question. I lost my original Apple TV remote. I programmed my TV remote to learn the controls. I'm using that remote to try to put the device in DFU mode. Does the original Apple TV send out a different code when both keys are pressed (Menu + play/pause) and my TV remote doesn't perhaps?



your problem is you don't have the silver remote and it can only be done with the silver apple remote, so you have 1 buy it or 2 barrow one

I have the same issue. I can finish the first step (creating the IPSW), Once that is finished it asks to connect usb (which is already connected from step one) and enter into DFU mode. I hold the "menue and the play/pause" button until the ATV led blinks rapidly (aprox 7 - 10 seconds). The promt sits there forever "waiting for device to enter DFU mode". I have let it sit long enough for me to clean the garage, cook breakfast, play fetch with the neighbors dog, take out the garbage and take a shower (aproximately 2.5 hours). Still, it sits there just like afew of the guys I use to work with and does absolutely nothing. Yes, its a ATV2 (A1378) and I have the silver remote. I have tried several micro usb cords, restarted my iMac (10.9.3), updated iTunes (11.2.1), updated Seas0nPass (0.9.5), ran disc premissions, prayed, done a few indian ritual dances and retried all of the above at least ten times. Still, stuck at "Waiting for device to enter DFU mode..." Any help would greatly be appreciated, otherwise I might just start drinking again!

Have you tried plugging in the power cord

No, I have not. I didn't see anything in the instructions that said to use the power cord. I will try that and get back to you and let you know.

That did the trick as far as it recognizing the ATV in DFU mode. Problem now is, it isn't jailbroken when it says

it's complete. Any suggestions?

Try this:  
- connect via usb to the computer and don't use the remote yet
- when prompted to enter DFU mode, plug in the power cord and don't use the remote yet
- when the light starts blinking rapidly (every 0.5 seconds) disconnect the power cable
- use the remote to enter DFU 
 This has worked for me many times and I hope it does for you too. 

Watch the YouTube video that is linked on the setup page.  It will tell you when to put the power cord and when you can pull it.


Watch the YouTube video that is linked on the setup page.  It will tell you when to put the power cord and when you can pull it.


I can't seem to locate the video - would you mind providing the link to the setup page you are referring to?  Much appreciated.


Installing process stop when is "Extracting software..."  Error messege: "Firmware restore faile"  Please, help!