Apple Tv 2 5.0.2 (4250) unsupported

No… the updated 9.4 did not solve my issue.

Unfortunately, I can tell you what NOT to do at this point since I just lost my 5.0.2 because of my stupid attempt to defeat this situation.

Except for a very few posts from posters who seem to have solved their problem, I thought that this could not be a universal issue since there has been no subsequent corroboration.  So feeling like I do with many of the Seasonpass issues that arise, I persisted in trying to overcome this issue.  And with the new 9.4 release, I thought there might be a solution.  Had no effect on my ability to save signatures or start a 5.0.2 IPSW download.  

Frustrated, but undaunted, I somehow and inexplicably got the MAC version of SP 9.3 to start a 4.3 (8F455) IPSW creation.  Funny… because iFaith could neither download the blobs nor FIND any blobs on the Cydia server for this ATV, but great!  I rationalized that somehow, despite the iFaith message, there WERE earlier signatures saved and I was now lucky to be retrieving them!

Those much more knowledgable then me might already see the RED FLAGS rising at this point.  And I knew that by attempting anything without saved signatures – something I never do – is risky, but this jailbreak was proceeding flawlessly, even giving me the usual 4.3 “bugginess.”

But, alas, I ended with a iTunes 1600 error which I hoped would be a phantom one.  No such luck as you know right off that a fast blinking light upon connection is not good.  

Then I reconnected to iFaith and got the message shown in the attachment.

I also reconnected to SP on my MAC and had to laugh when I got this message: “ONE OR MORE OF THE FLASHED IMAGEDS ON THE DEVICE DO NOT CONTAIN AN SHSH BLOB (USUALLY HAPPENS WHEN USERS FIND FUNKY TUTORIALS ON THE WEB TO DOWNGRADE WITHOUT BLOBS).” 

Now, instead of a beautiful 5.0.2 un-jailbroken ATV, I have a beautiful and jailbroken – and tethered – version 5.3.  I’m not happy and show again why not savings your signatures while trying to jailbreak is just a mistake.

My frustration got the best of me, I stumbled… fell… and now can never get up here. 

BUT IS IT REALLY IMPOSSIBLE TO (untether) JAILBREAK VERSION 5.0.2 NOW???

So lets see… Cross off VERSION 4.4.4 since that can be a complete mess to deal with.  And run from an unjailbroken version of 5.0.2 as well because you’ll never jailbreak in that version?

Is this really what it has come down to?

 

I finally got it to work!

 

I have a apple tv 5.0.2, I’m running windows 7 64bit.

 

  1. open the latest ses0npass,

  2. right click “create ipsw” and select “save firmware signatures”

  3. when it’s done, it’ll tell you to unplug all cables from your apple tv, DONT DO THAT!

  4. the led is still flashing, don’t worry, right click “create ipsw” again, select 5.0.2

  5. now it reads “waiting device to enter dfu mode”, something like that, and the led is still flashing, now just

press menu and play button for 7 seconds and more, then it’ll enter dfu mode again. now seas0npass will continue to

create a custom ipsw for you

  1. it opens itunes when the ipsw is created, now just go to itunes, press “shift” while clicking “restore”, select the

custom ipsw in documents/my documents/seas0npass then wait for a few minutes, your apple tv will be jailbroken.

 

I think you misunderstood my issue…

Niether Seasonpass nor iFaith would save the signatures.  And upon connection and a right click on the 5.0.2 ISPW option, I would only receive the hated “device is ineligible for this version” message.  Nothing would change that.

Perhaps my Apple TV had issues, and hopefully my experience is not indicative of a universally felt version problem.  Yet, this Apple TV booted fine, connected via Wifi, and absolutely showed itself as a version 5.0.2 in the Settings menu.  And still, SP acted like this Apple TV had no relationship whatsoever to 5.0.2 (9B830), or any other untethered version.  All I was ultimately left with was a 5.3 jailbreak.

Luckily, I have no more non-jailbroken 5.0.2’s to test the theory.

However, I would appreciate to hear from others about their 5.0.2 experiences.

Unlike my 4.0 and 4.1.1 that seem hopeless now, and perhaps always have been, these 5.0.2’s really should not be a problem.  I hope they’re not.

 

Hi MaxieWagner, I’ve got the same problem dumping blobs for 2 x 5.0.2 units, iFaith chucks up an ‘invalid k66ap error’. Tried every version of iFaith, Seas0npass, PC and MAC. No joy. There was a couple of other people who couldnt jailbreak their 5.0.2’s either in another thread, no one had any suggestions unfortunately :frowning:

There are no suggestions, unfortunately.  You will have to jailbreak to 5.3 I am afraid.

Ian82, based on your postings, you jailbreak LOTS of Apple TV’s… everyday it seems.

Surely you have PERSONALLY attempted to jailbreak a 5.0.2 in the past month.  What was your experience?  Did it mirror ours?

I guess I can understand why the oldest versions (4.0 and 4.1’s) would have no untethered jailbreak options at this point… But why would version 5.0.2, smack in the middle of all the releases, now be the ONLY one that is somehow no longer capable of having its signatures saved or being recognized by Seasonpass as a 5.0.2? 

You don’t run across ANY jailbroken 4.0’s or 4.1’s.  But there are a TON of jailbroken 5.0.2’s out there – including many I previously jailbroke myself.

This situation makes absolutely no sense. 

 

For the record I got curios and pulled out one of my ATV’s which had 5.0.2 on it and ran attempted to save blobs via Ifaith… it saved just fine.

http://img18.imageshack.us/img18/3073/clfb.jpg

I used iFaith v.1.5.6 on a windows 7 machine.

Thanks for taking the time to do that, Carpenter! Really appreciate it.

I HAVE to believe that I simply had a “sick” 5.0.2 – and this is not a universally experienced 5.0.2 version issue.

Curious:  Could you also save the signatures with 1.5.8 or 1.5.9?  I’m still not sure how to obtain iFaith versions earlier that those two I possess – or why they would even be necessary to do this, if they are.

Also… I notice that your picture shows a 7.0.2 (11A502) signature which does not correspond to the latest SP 9.4 release…

 

I tried it with 1.5.9 and the program just sat at exploitation stage, so I think that might be your problem. I re-tried with 1.5.6 and was able to save again just fine.

 

Here’s a link to all th ifaiths you can stomach… http://www.filecrop.com/iFaith-v1.5.6.html

Don’t know how safe it is but all I did was a search for iFaith-v1.5.6 and that was the first one.

 

I have SP 9.3, I don’t think SP 9.4 is out for windows yet

Thank you again, Carpenter!

FWIW, this is a workable link to iFaith version 1.5.6   http://filetrip.net/l31905-iFaith-(Windows)-1-5-6.html

Filetrip.net is a safe site as judged by MacAfee. Scamadvisor, Siteadvisor, etc.

Unfortunately, I just cannot seem to get ANY version of iFaith to dump signatures.  I just tried to do it with a healthy ATV 5.1 and just cannot get past the exploitation phase. 

But using the same PC and Seasonpass 9.3, the signatures get saved flawlessly to the iFaith Server, and the jailbreak proceeds without issues.   iFaith WILL confirm that Seasonpass DID successfully upload the signatures to the iFaith server – something the iFaith program itself could not. 

The issue with my 5.0.2 that seemed “unsupported” was not only that iFaith would not save the signatures – but Seasonpass would neither save the signatures nor recognize the ATV as an  “eligible” version.

Maxie, if your ATV2 returns the invalid response k666.ap whatever it is, then you will not be able to dump blobs because iFaith cannot get a response from the ATV2.  I have a couple of 5.0.2s that return that error, one of which I have put on 5.3 and the other I cannot get to restore even on 6.0.

I have indeed jailbroken many 5.0.2s but you should not proceed with Seas0npass unless you have dumped a 7.21Kb blob and then downloaded the 7.23Kb blob that iFaith uploads to Cydia.  Save these two and then you can proceed with SP (I use 0.92 for win).  It will work.

Thanks for the response, Ian.  Regarding the 5.0.2 I eventually was forced to update to 5.3, I could never get past the “exploitation” phase on every version of iFaith I tried, and none of my versions of SP would save the 5.0.2 signatures.  iFaith did confirm that there were no saved signatures for that ATV.

A right click on the 5.0.2 IPSW option would only result in the “not eligible for this version” message.  

In your experience, is this problem specific to 5.0.2’s or is this a random problem that affects all versions? For some reason, and I confirmed it going back through the threads, it only seems like version 5.0.2 is cited as a problem in this way.  

Should I be especially leary of acquiring 5.0.2 units?  Are you?

For better or worse, I’m going to get a fresh crack at one of these as I have a 5.0.2 on its way.

I’m usually excited when acquiring a 5.x untethered unit.  I can’t say I feel that way now when it’s a 5.0.2.

Hi Maxie

In windows, it is quite common for Seasonpass to return that string - “This Apple Tv is not eligible for this version”. You need to be firm with it and make the same request again, then it works more often than not.

if you can’t get past the exploitation stage I suggest that you always have iTuunes and TU open while you are trying to dump blobs.  Quite often it is a good idea to click on fix recovery in TU while in DFU mode. iFaith often gets stuck at exploitation stage.

I am more wary now of buying 5.0.2 unless the seller sends me the ECID.  Then of course I can download the blobs for myself (if any) and if not I do think twice before buying.  I have had maybe 5 5.0.2s that behave as yours does but a few hundred that behaved normally.

More troublesome to me is the number of 4.4.4s non-jailbroken that dump 5.81KB blobs and uploda 5.83KB blobs to Cydia.  These cannot be jailbroken and this has resulted in my no longer buying non-jailbroken 4.4.4 units.

I’ve now had it with this version!  When offered, I wiil value an unjailbroken 5.0.2 as much as I do a 5.3.

My new crack at the 5.0.2 issue arrived yesterday – and I’m screwed again!!

I’ve tried every “fix” suggested – and multiple, multiple times.  I am simply SICK of seeing the negative messages I cannot escape while trying to do this – despite my unprecedented persistence.

My 5.0.2 signatures simply cannot be saved and, of course, SP continues to return the message that this Apple TV is “ineligible for this version.”

My latest “batting average” on these 5.0.2’s is .000.

I quit!

How big are the blobs, Maxie?

Dave, click on it again.

I was unable to dump any blobs using IFaith.  I just kept at it, and finally was able to get past the “exploitation” hangup.  However, I ultimately got the “Invalid Response Was Received From The Device - K66AP Error.”

I assume that officially means “game over” for this 5.0.2?

Yes?