Apple TV 1st Generation: Update failed. Apple tv could not be updated


I have a problem with my apple TV 1st Generation.

I did a Factory Restore and now i have


Software Version 2.0.2 

Software Build 120

OS Build Version 8N5461

EFI Version 00DA.B04

GF Version 3.1.0/2.9.50


I wanna upgrade the Apple TV to Software Version 3.0.2 which is the last but all i get after downloading and installing the update is the same message



Update failed. Apple tv could not be updated. Make a Factory Restore


I have made over 30 Factory Restores but the same message all the time.


I read that the solution is to change the dns server to and ---> Fail

I also tried to update it with dhcp by cable ---> Fail

I also took the wifi card out and did the update only by cable ---> Fail

I downloaded the update in Apple TV and when it restarted i took the cable off ---> Fail 


The most annoying thing is that it downloads the update and when it starts installation of 3.0.2 then the message appears.

Can somebody help me please, so i can update my Apple TV


Thanks in advance.

Did you figured it out? I am having the issue with updating to 3.0.2, update downloads but does not install. “Update Failed” I tired all the steps that you listed.

Please advice

thank you


Still no solution. If anyone can help please advice.


thank you. 

Sorry I can’t help you.
I took a friends apple tv hard disk and I duplicated it.
Now it works fine.