Apple 3.0 --> Apple 2.4

short story:
bought a 40gb ATV, and aTV Flash several days ago. did not know Apple 3.0 came out yesterday and aTV Flash is not supported.

problem:
i was following the instructions Part 2, Step 1: 1. Update to most current software through AppleTV Settings > General menu.
Result: Apple 3.0 was loaded. i then continued on with the install process and obviously FAILED.

possible solution (if possible, aTV Dev Team, please confirm):
can i create a boot disk (USB) with Apple 2.4? (if yes, how?)
fyi - i pulled down the Apple TV 2.4 .dmg file from the “web” (will that help?)

the idea is that if i could go back to 2.4, i could then use the current aTV Flash image to do what i want with my Apple TV.
i understand that the Dev team is hard at work at getting a 3.0-supported image out “soon”. however, i would very much like to spend some time getting comfortable with the install process now than later.

or… am i hosed? (until the aTV team creates a 3.0-supported aTV Flash image)

thanks in advance.

I hear ya macarena. I didn’t even realize auto update was on! Now when I factory restore, it reverts to OS 1.0, well below aTV Flash minimum. If I can downgrade from 3.0 to 2.4 until an aTV Flash update is available, that would be amazing. I can’t even find aTV OS dmg’s online though. Where did you get yours?

Of course if I figure out how to downgrade before the update I’ll let you know.

Derek.

i pulled the files from http://www.trejan.com/projects/appletv/

perhaps “trejan” could help with our issue, but i’m crossing my fingers that the $49.95 i paid for aTV Flash will give me some “really good” guidance on how to resolve this problem. yes, i expect tech support when i pay for software. i think it’s only logical.

however, if you do figure it out - let the forum know. it looks like we’re on our own for a few days (maybe weeks) by the looks of things. :wink:

here’s my not-so-genius idea:

  1. create a bootable USB with the 2Z694-5660-029.dmg (Apple TV 2.4 -from the trejan site)
  2. power down atv device
  3. insert bootable USB
  4. power up atv device
  5. chant some “ho-ho-magic-supernatural-superstitious” words
  6. voila! back to 2.4

if only i can get someone to confirm that this approach makes sense, or add the necessary steps to make it work, i’ll be good to go. thing is - it’s much too simple and i doubt that this is it. but i haven’t tried it for fear of further damaging my atv. again, 49.95 - i could use some help. :slight_smile:

all i’m really asking is for someone from the atv dev team to tell me – “no, not going to work. here’s the workaround. also, we apologize for not providing our customers a proper notification regarding the 3.0 upgrade. apple pulled a fast one on us. we could have emailed each one of you (since we do have your email on file when you purchased aTV Flash) to advise you not to upgrade your units, or disable the ‘auto-update’ feature, but we sure as heck will do better next time. in any case, follow these steps in case any of you happen to have accidentally/inadvertently or knowingly upgraded your units to 3.0 (outline of steps provided and tested by our hardworking dev team).”

Fantastic! and I’ve got something for you too…

http://wiki.awkwardtv.org/wiki/Booting_from_a_USB_Thumbdrive

This details how to create a bootable USB stick using the downloaded 2.4 software. I wonder though if the other IR, SI and EFI files need to be used also.

Gonna try now :slight_smile:

http://wiki.awkwardtv.org/wiki/AtvPwn

Mac only, but here’s the basic steps to go from 3.0 -> 2.4:
Patch your currently installed 3.0 to install ssh
Run AtvPwn on a mac and tell it to upgrade ATV to 2.4
Execute, and it’ll installed a patched version of 2.4 that has ssh and any other plugins you specify.

That’s the easy way.

NEWS FLASH – NEWS FLASH

i took gbooker’s advice and am able to successfully revert back from Apple 3.0 to Apple 2.4!!!

here’s how i did it:

Enable SSH

  1. create aTV Flash USB Bootable disk - Flash Drive Creation Step 4 (aTV Flash Install and Setup Guide)
    **only choose FTP, SFTP, SSH option (default - grayed out)
    **deselect everything else

  2. power down Apple TV (running 3.0)

  3. insert USB disk created from step 1

  4. power up Apple TV

  5. you will see the firecore logo and upon completion of install process, remove USB disk, powercycle Apple TV device

    You have now enabled SSH on your Apple TV 3.0, proceed to next step

Launch AtvPwn

  1. download AtvPwn from http://wiki.awkwardtv.org/wiki/AtvPwn

  2. launch AtvPwn

  3. choose Apple TV Version 2.4 (default) and “pwn it!”

    This process takes a few minutes. DO NOT PANIC. Let the install process take its course. Your system may reboot at least 2-3 times. Monitor system availability via pings (if you’d like).

AND YOU ARE DONE!!!

you will notice that you are on 2.4 due to the change in interface. feel free to confirm ATV Version by going to Settings > General > About.

**i just noticed that the ATV found a newer version (3.0) of software and is prompting to ‘Update’ – DECLINE this for now until the ATV Flash team are able to come up with a 3.0-compatible build.

i will try and load aTV Flash in a couple of hours or so and will keep everyone posted. i hope this post helped some of you. aTV Dev Team, you owe me. :wink: j/k! keep up the good work.

i just finished installing the latest aTV Flash on my Apple TV (downgraded from 3.0 --> 2.4). everything looks really good at this point.

EDIT: IT worked anyway :slight_smile: many thanks!

Thanks for the post! Managed to get to a certain point, however when I run osupdate from the ATV I get this error:

2009-11-02 06:14:03.636 osupdate[182] Running on Apple TV 1.1+
2009-11-02 06:14:04.657 osupdate[182] Requesting update
Shutdown NOW!
shutdown: [pid 186]
sh: line 1: /usr/bin/wall: No such file or directory

System shutdown time has arrived
/System/Library/StartupItems/RemoteDesktopAgent/RemoteDesktopAgent: line 17: /System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/Resources/kickstart: No such file or directory
/System/Library/StartupItems/AutoBind/AutoBind: line 1: dirname: command not found
/System/Library/StartupItems/AutoBind/AutoBind: line 1: basename: command not found
Stopping Network Information Service
Stopping Apache web server
/System/Library/StartupItems/Apache/Apache: line 33: apachectl: command not found
Stopping network time synchronization

It seems to continue the script though - is that ok?

The windows version does not have the option of unchecking. Any ideas?

Hi

I’m just gone thorugh the same thing, ATV updated to 3.0 and now ATVFlash isn’t working.

I’ve followed the instructions above, created my usb flash with nothing ticked and rebooted my ATV with this version.
ATV is working with 3.0, no problem.

I’ve downloaded AtvPwn and tried to run it, I click on ‘pwn it’ and it starts to do something but then it crashes giving me an error “atvPawn quit unexpectedly”

Any ideas what is causing that and where to go from here?

Much Thanks

Colin

colinstewart wrote:

“I’ve downloaded AtvPwn and tried to run it, I click on ‘pwn it’ and it starts to do something but then it crashes giving me an error “atvPawn quit unexpectedly””

i can’t help you with this one. although at first i had doubted my approach for i have read somewhere that apple no longer provided the 2.4 image on some redirected URL. i didn’t expect for the 2.4 downgrade to be successful, but it worked for me.

i suggest trying atvpwn again. if it doesn’t work for 2.4, try 2.3, then 2.2…

Disclaimer: i am not affiliated with the good people at atvpwn, and no guarantees are implied in my recommended approach. i am merely a fan of their talent and great product. it worked for me this past weekend.

very interesting. i did not know this. i just read through the install doc for windows and you are correct.

my suggestion - do it anyway. since the aTV Flash will enable SFTP, FTP, SSH, you can, theoretically, move onto the the atvpwn stage and revert back to 2.4 (or 2.3, or whatever image is working).

if you feel like you need a “do-over” here are the exact steps i took:

  1. restore Apple TV to factory defaults
  2. update Apple TV to ‘latest’ image (Apple TV 3.0)
  3. install aTV Flash (latest version) with only the SFTP, FTP, SSH options (see earlier posts)
  4. aTVPwn it! (downgrade to 2.4)
  5. install aTV Flash (latest version) with all Standard and Advanced options
  6. YOU ARE DONE!!
  7. pray that hulu is supported in the 3.0-compatible release. :smiley:

Disclaimer: the recommended steps were executed on my macbook pro (running snow leopard) and 40 gig Apple TV appliance. my apple tv reverts to Apple TV 1.1 when reset to factory. other OS - windows, linux, etc. were not tested. i suggest folks using non-mac OS to try the steps outlined and share their experiences. this helps the community while the dev team is working on a hulu-compatible release… err… i mean 3.0-compatible release. :wink:

http://forum.atvflash.com/viewtopic.php?f=5&t=1982