App Crashes Deleting from Search Both iOS and MacOS

Prior to 7.4.5 update this was no issue but after update when trying to delete a file directly from the search results the app immediately crashes without fail. Have tried reinstalling app and no change. I have posted the similar issue in the Mac forum as the same issue happens there. Wondering if I’m the only one with this issue and if there is a potential fix coming in an update.

Are all of these devices that are crashing using the same iCloud user ID?

Also, what devices are you seeing this on? Model and iOS version?

Yes, both my iPhone 12 Pro running iOS 16 and my MacBook Pro running MacOS 12.6 are on the same iCloud account.

In the most recent Infuse update (7.4.5) when trying to delete files from the server the app immediately crashes. This is also happening on the iOS app (7.4.5). Have not figured out a way around this and it was working just fine with 7.4.4.

What server are you running? Like plex, emby, smb, nfs, etc. and local or remote?

I am using an FTP server running from a computer in which I connect both locally and remotely. On 7.4.4 and previous versions this worked just fine but now when I press the last button to delete a file it immediately crashes. Same behavior on both Mac and iOS.

Can you post a diagnostic code after you restart infuse after a crash?

The diagnostic code that pops up when I use the “Email Us” link in preferences is NXK72. Let me know if there was something else you were looking for.

1 Like

So I just realized today after some testing this only happens when I try to delete from the search. In the past I have searched for files and deleted from the server from there. Now the app crashes when I do that but I can delete files by going through the folder structure just fine.

Since it’s only from search and on multiple platforms I moved your other thread from the Mac file managment and combined it here and changed it to “general”.

Thanks for the report!

Just to confirm, if you attempt to delete files outside of search then everything works as expected?

That is correct. When I navigate to the files via the folder structure and delete there is no issue. Only an issue deleting directly from the search results.

1 Like

We have a fix for this coming in the next update (7.4.6).

Thanks for the report. :slight_smile:


Great! Thanks for the follow-up.

This has been resolved in today’s 7.4.6 update. :slight_smile:


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.