Anybody experience using NAS ?

Hi again,

i´m looking forward to use ATV for playing my whole music collection via remote (ipod).
I have the 160 GB model, but need more space…i thought using a NAS with 1 TB would be nice, storing photos, music, videos etc. making them avaiable all over the house. Anybody already having something like that in use ? What kind of NAS is the best for that, what protocols are needed, is streaming of video also possible (including TS_video or DIVX) ?

Thanks in advance,

Best regards -cortex-

hey there,
there’s a few other threads covering your question.
aTV Flash can enable AFP & SMB network sharing in both directions, although enabling it gets a little more complicated if your AppleTV shipped with anything later than v1.0 software (and there are other posts covering that too!)
and those that get it working experience varying results, from great to unusable.
i’m still struggling to get mine to recognise/connect to my Windows Server 2003 shares via SMB :frowning:

I am having good success with the D-Link DNS-323 NAS box. You can add one or two drives and configure in differing RAID modes. I am using it in a RAID 0 (striped) mode for performance and have two 750GB drives for a total of 1.5 GB of storage. I can mount it via SMB and access all files. Playback seems fine for most things. I have decided to stick with H.264 for most HD encodes. These are playing back 16x9 with great quality so far even over the network. I do have the D-Link DIR-655 802.11n so that helps in combination with the ATV’s 802.11n. The DNS-323 has Gigabit ethernet and that plays nicely with the DIR-655 Gigabit ethernet port. I am also running Twonkyvision on the DNS-323 which allows it to stream to any UPnP device like the XBOX 360. The H.264 encodes also playback fine on that device.

Hi,

I have a Dlink DNS 323 NAS too, how did you get AppleTV to smb mount it?

I have tried configuring in DVD (NitoTV) network settings, but after I key in all necessary info (smb, IP, volume name, tried both with and without login/password), and click mount it, it always seems like it is ‘resetting’ and go to the screen that shows the Apple silver logo, flash it one time, and back to menu.

Any help much appreciated.

I’m thinking it was something like smb://192.168.0.199 for the address

It’s been a while now. Once it is set then you just have to go into Network and do a mount but it doesn’t show the original string anymore.

Not sure if you have to have Twonky running on the DNS-323 for it to work or not.

You need to install the combo update as suggested at http://forum.atvflash.com/viewtopic.php?f=10&t=151
This will enable smb mount.

Cheers,

Gus

So after a long investment of time trying to connect with my D-Link DNS323 I have figured out what I was doing wrong.

Share Name: Whatever You Want
Network Address: 192.161.X.XXX <-- get the ip address of your DNS and insert it here
Type: SMB
Volume Path: Volume_1 <-- This is where I had a problem in OSX 10.4.9 this drive shows up as VOLUME_1 but on the device it is not in caps, its caps and lower case.
Automount: ON or Yes

The NAS now shows up automatically even if the ATV crashes and restarts.
Which brings me to the next obstacle and that is that ATV doesn’t handle 720p over my network very well. I use a wireless N router, and its not that playback is choppy but it just simply restarts after a few seconds.

I’ve built my own NAS using netatalk on a Linux server with an 8 drive hardware raid array. I connect my AppleTV to it via AFP. Works flawlessly, no lag playing movies. I used to have a drive hooked directly to the ATV via USB, but I didn’t like worrying about what I would do if the drive failed. I’ve got about 600GB of movies and TV shows I’ve converted by hand from DVD so it would have been disastrous to lose all of that time and effort. Plus I get to transfer data to my NAS at gigabit speed instead of 100MB.

If anyone cares I can provide more details on my setup, since I found most of the fabricated NAS appliances didn’t provide the features, flexibility or performance I required.

Cheers!

Hi,

I got my AppleTV to mount my DNS 323 successfully with SMB.

However, I find playing video from files off the NAS a little jerky (would happen every 5 seconds or so). It happens for 2 Mbps video files, and DVD iso images too. I tested the network bandwidth between the NAS and AppleTV and it looks fine, transferring at close to 10MBytes/sec (yes, 100Mbps).

What can I tune to get the video playing smoothly?

Hello.

Could one of you who managed this feat tell me how you did it ?

Did you have to “Add Manual Share Point” ? under the DVD/Menu ?

or did your drive appear in the DVD/Network menu automatically ? Mine appeared as “AFP on LaCie-New” but apparently AFP does not work onAppleTV’s with 2.3 firmware. But why cant I see the SMB version which I would expect to show as “SMB on LaCie-New” ?

I tried Winesap’s solution but no luck, timed out. Not sure what I should be typing under “Volume Path” where he types Volume_1. The NAS drive appears as “LaCie-New” in Finder whilst the share is “Video_New_2TB”.

Any suggestions anyone ?

regards
Shaun