Another stuttering issue (specific to tvOS)

The film is Four Lions. Ripped using makemkv to a .mkv file. The file plays normally using with vlc’s player and with iOS on an ipad. but with tvOS (v 6.1.5) it stutters throughout. The audio appears to be playing fine, but it’s as if there isn’t enough bandwith to play the video. It jumps repeatedly and eventually falls out of sync with the audio.

It’s not my network, as I tried a number of other mkv rips on the same Apple TV and they are all playing fine. This rip stutters across all my Apple TVs.

I tried ripping the disc a second time but that hasn’t made any difference.

Any ideas?

infuse is broken with remux or big files uhd on tvos beta. wait …

As far as I know I am not running a beta version of Infuse.

tvos beta ?

TvOS on the ATV that is connected to the main tv in the house is v 6.1.5.

I’ve just checked a second ATV which is running v 5.9.4. Same issue.

Are you running tvOS 13 beta?

You can check the version info in the main Apple TV Settings > General > About menu.

I’m running tvOS 12.4 (16M568).


If it’s just this one file, it may be something file-specific.

Any chance you’d be able to send in a sample we could review here?

Uploading now but:

  • I took a three minute edit from the middle of the film using Avidemux. Default settings - I just selected an A and B point for the excerpt.
  • the clip plays in vlc player
  • the clip is unplayable in Infuse using Apple TV. The soundtrack is white noise and the picture locks solid after a few seconds. This is a much worse performance than the complete file using Apple TV.
  • using Infuse on my ipad, the picture is pretty smooth but the soundtrack is white noise.

As a reminder, with the original, the soundtrack is fine, but the video stutters and falls out of sync with the audio.

Apologies for the delay here, it looks like this one slipped through the cracks.

Testing your sample in the current 6.2 version of Infuse on tvOS 13.2 the video appears to play smoothly.

Infuse does select the first audio track, which appears to be just white noise…but selecting one of the other tracks allows the correct audio to be heard (see attached).

Thanks James. I will check this out later today.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.