"An error occured" AFP connection failed: unreachable"

I installed Flash Black yesterday and all was working fine then today when I try to access my files via AFP I get this error. I’ve tried switching off AFP on my MBP, deleting the share details on ATV then switching it back on - but still getting the same error. Very frustrating. 

Can anyone please advise how to fix this??


I’m having the exact same problem and have had it since I did the upgrade. I haven’t had any luck fixing it. Oddly enough, the problem does not happen in XMBC, so it is a problem which apparently only affects the media browser portion.

Same here using à synology.
Since the last update of atv flash it fails to wake up my nas.
I Need to always use my iPhone or pad to wake up my nas befor atv finds it.
Hope you fix this asap

This tends to happen with my Drobo quite a bit (Gigabit connection) I’ve found that backing out and trying again once or twice almost always resolves the matter.  would be great if they had a slightly longer timeout.

Frankly, this is the main reason I even use the Apple TV, much less Flash Black. I find it to be extremely buggy – especially the media player – and have no problem whatsoever using XMBC on the same Apple TV with no errors, network issues or anything else. I’m using a Synology as well, but I have no problem accessing it from literally every other device in my house.

!!!  Me too!

Solaris Express, Running netatalk - worked just fine with a previous version of firecore, works fine with a plethora of macs other devices.  Simply will not let me attach to my media…

DEVELOPERS! HELP, Please?  I see at least two major “updates” to AFP code in this release:  - “fix AFP pause after long wait” (never experienced that I don’t think…) and “Added DSI ping for better operation with AFP shares”…

My error comes back rather quickly - could this last improvement be my stumbling block?

UPDATED 2 hours later:

Issue at my end appears to be AFP 3.3 support, which to achieve, required me to upgrade netatalk from 2.1 to 2.2.2…  I just did this, lit up aTV Black and was successful at connecting!!  Woot woot!!  All better at my end…  Good luck, all!!

Hello from Belgium.

Me too … I have the same problem. it suddenly appears !?

  • connection to internet works fine => so no cable/network problem.

  • I can access my Synology from my mac with same user rights and without problems => my server works fine

Only the “My media file” doesn’t work anymore. One week ago everything fine, and now I’m blocked with my most used functionality!

What can we do ??

Personally I have found the Media Browser component of this product to be unreliable at best and I have stopped using it. And that’s the fix as well…install XMBC and you won’t have any of those network/Synology issues if you play your media through that plugin.