"An error occured" AFP connection failed: unreachable network or incorrect login/password

Apple tv software: 4.2.2 (2203)

Breaked with Seasonpass 0.7.6 (73)

Latest Mediaplayer

Nas: synology ds209

ATV flash black beta 6


Now to the problem, before I didnt have any problems connection to my nas via AFP.

But now nothing works anymore, I find the nas, enter the login and password (tried other accounts, restarted the afp share on the nas, rebooted the nas)

When its connecting I get the error: “An error occured” AFP connection failed: unreachable network or incorrect login/password


I trippelchecked all the setting and everything is normal, or at its supposed to be. Everything worked fine untill I updated mediaplayer

I am experiencing the very same AFP share problem after updating to beta6. Refuses to connect to my Synology DS-409+ NAS running latest software version. No problem with previous aTV Flash (black) beta 5/Player 0.6. Hope for some help from the forum.

We’re looking into a few similar issues.

If you haven’t submitting a bug report yet, it would definitely help in tracking down what’s going on.

I was very exiting about the new Media update last week, but yesterday I look a movie in the afternoon that was working fine,yesterday evening ,I start an other movie ,than came up the following sign  “An error occured” AFP connection failed: unreachable network or incorrect login/password"

I try to do everything to connect again, restart the AppleTV2,overflow,restart my computer,take out all the cables and plug them in again,but nothing works. I did nothing with my computer like installing new software or new programs! Everything was like before!

After days of fine working this came up as very disappointing!



This morning I start again and same sign came up, An error occured" AFP connection failed: unreachable network or incorrect login/password.

Than I go to Media/settings/add share and start to install a new share, the share with the same name shows up, I add this share again! Now I had 2 shares with the same name than I tested and saved the second share and delete the first share, all with the same name. 

When I start up Media to see a movie everything was Ok and the sign “An error occurred AFP…” was gone and the movie act as before!!!

It is very disappointing when you go to deliver a program to watch and there is always something wrong with that and make it uncertain to enjoy looking at it.





Same here,

Have tried everything on my Synology 1511+, simply cannot get the connection to work, where it did previously.

AFP share to my Macbook Pro works fine.

Have submitted bug report, eagerly awaiting 0.7.2 so we can resume watching our DVD’s.


I had this issue however restarting my wireless network on my macbook fixed this issue


Yep my Macbook was fine too (wired or Wireless), but problem with my Synology NAS which worked fine on previous beta’s, hopefully the guys are on it!

After Update to Beta 7… for me… problem is NOT solved. i did for 3 times: Restore Apple TV to factory settings (with iOS 4.3), loaded season pass again… loaded atv flash again. did the jailbreak again… installed everything again. restarted my network, tried new ip addresses, got back to the old ip addresses… changed passwords… nothing helps. with beta 6 (media player 0.6) it all worked fine. since media player 0.7 nothing does. 

I tried to reinstall everything clean for three times now, and it all comes to the same error: An error occured" AFP connection failed: unreachable network or incorrect login/password

it is Very confusing an frustrating…

I don´t know what to do… did everything i can imagine and everything suggested here in the forum… :frowning:


i have a synology diskstation ds211j

AFp connection to my TimeCapsule works FINE… that its strange too…

Add me to this problem with a DS411j. Seemed to happen before the last update less frequently but not it seems like something that happens much more at least today. This is the only thing on my network that seems to have this problem.


I have updated my Synology DS-409+ NAS to the new firmware version 3.2-1922 and the connection problem is now solved.

The new firmware improves Apple AFP connectivity and other Lion related issues !!! See the release note.

I am now on aTV Flash (Black) beta7 and Player 0.8 - both updated through the maintenance feature.

Thanks for following up. :)

Hopefully this solution works for others as well.

I’m current seeing the same issue but I’m running a custom build on my NAS (Netgear Stora). Currently I’m running Netatalk 2.2 beta 4 for the AFP, I’m going to try and get the latest build of it running it on there, as that might be the root of the issue as the authentication has changed quite a bit in AFP 3.3 as I understand it.

Fixed for me.

Had to re jailbreak as an install of Xbmc went haywire, with latest version and Synology 1511+ upgraded to 3.2 just released, I can once again connect via AFP to the synology NAS.

So lots of steps forward, thanks guys! but one small step back, AC3 is giving decoder error on my receiver so disabled and stuck in pcm48 for now :frowning:

Its still beta and these things happen, updates and features turning over nicely, keep up the good work.

Same here - right after Synology update 1922 (released last week) issue with AFP gone.

this is not the trick for me…

I still get the unreachable network error, a restart sometimes works but most of the time it won’t. 

When I select a recently watched movie on the same AFP everything works.  Stop the movie and the AFP share can be connected…

My AFP is on an Apple Timecapsule 2TB, the ATV is wired directly to the TC.


I have send an error report. sn DCYFKDKEDDR5

We’ve got a number of AFP fixes coming in the next update.

Stay tuned.

Same problem over here.
No upgrade. Brand new install.
Worked fine for a couple of days . Now afp connection problem.
Data is on a sinology 207+ nas.

It is not acceptable that after almost one year after buying we are still doing the beta testers for fire core .
Will we be entitled for one year of upgrades once the non beta is out?
After all we worked providing feedback for all this time.

Furthermore you should provide some way of completely removing the mp and not having to reinstall everything at each update

As mentioned above, the upcoming version will have a number of AFP related fixes.

Also, the license period will actually start over once the final version is released - all the time during this beta phase will be a free bonus for you. :)

0.9 fixed this issue for me.