An error ccurred in latest Apple TV

Hello. I’m having a problem with several videos that they don’t play at all, just say An error ocurred, and it’s inmediate.

What I could gather is that this videos don’t show any data of the file in the details, only the movie information, but no resolution, or DV, HDR, Audio.

Also I could check with MediaInfo that they are SMPTE ST 2094 App 4, Version 1, HDR10+ Profile B compatible.

My Apple TV is the new 128gb model.

I leave here 2 of the files info that have the same behavior.


File1.txt (31.3 KB)
File2.txt (6.8 KB)

I saw something in another post which perhaps isnt a fix but might narrow down the issue.

Perhaps if you disable and it does play then it could be a HDR support thing, or maybe you need to enable this HDR10+ setting if it is not. Given that HDR10+ is kinda what Dolby Vision is to HDR10, DV took a while to work properly on ATV and Infuse I found and to support all types but it did mostly always fall back to HDR10 and sometimes show the title but everything was purple :slight_smile: Seems to always work now.

Have you set the ATV in its settings to output natively to HDR10+ and does that work? IE I run my ATV menus in Dolby Vision, forgive me for speculating by I assume there is a HDR10+ setting there to run as that instead of standard HDR10 or Dolby Vision. Matching Dynamic Range may help also, apples document is here: About 4K, HDR, HDR10+ and Dolby Vision on your Apple TV 4K – Apple Support (UK)

Sorry if this is no help.

1 Like

Hey, probably is something with HDR10+, but I couldn’t find that option. I use the menus in SDR, I’ve tried changing it to HDR but no option appeared.

The thing that is weird to me is that not only they don’t play, Infuse doesn’t seem to recognize the files or their properties, and I believe that’s not the ATV player.

Thanks for you help anyway, maybe later I try more modes.

In the Apple TV Settings what HDR modes do you see in the Video and Audio section? You should see all of the HDR modes: (Hopefully this link is to the right time in the video)

If your TV supports it (and your AV receiver if your ATV passes through one) then you should be able to run the menus in 4K and HDR10+, for me I have an LG TV so I run 4K Dolby Vision, my TV does not support HDR10+…but the point is I can fun all the menus at 60hz 4K Dolby Vision and therefore can achieve the same in Infuse…broadly speaking.

Yeah it is weird because even in my second ATV room which is for my daughter its a 1080p TV which does not support any HDR but the HDR files will still show the properties.

Usually one of the big guns here allow you to upload your content to them and they will verify for you, I might be able to test the same for you if you can link me to the content, would be happy to, the HDR10+ wouldnt work but it would be interesting to see if my Infuse shows the details of it.

1 Like

Yes, I didn’t see any HDR10+ option in video settings. I do know that my TV supports it but I’m not sure about the audio receiver. I will try connecting directly to the TV, just to test because I need the receiver anyway.

In any case I think if I don’t have HDR10+ on my TV or receiver, it should play like a regular HDR file.

I don’t know if I can put those links here, I’ll send you a PM. Thanks.

That is weird, it should be there on the latest 4K ATV (3rd Gen), actually it should be there even if the TV doesnt support it…or the AV unless they have changed that. My AV didnt support DV when I first got my Apple TV and when I did try it the screen sketched out completely because the option was there for me to use even though the AV wouldnt have it. I connected directly to the TV to make sure it would work then got myself a new AV that did support DV. In fact im pretty sure I can still enable it and watch my 1080p TV get very upset :slight_smile:

This is a little weird, what options do you have there?

Got your PM, ill check out those files today or tomorrow for you see if they play.

I have SDR, HDR and Dolby Vision. Maybe if you have Dolby Vision they don’t even give you the option of HDR10+ because it’s similar or better. In the video you showed me they don’t have DV.

I think I saw somewhere once you enable HDR then the option is there for HDR10+

It is odd why it would be missing all together.

Well I tested everything and it was the receiver that didn’t support HDR10+, but, that was not the problem anyway. The HDR10+ option appears when you have HDR and HDR10+ and it just enables you to fall back to normal HDR, because in the resolutions list HDR is not listed if you have HDR10+, so it’s like selecting 4K HDR (60hz).

I tested every mode, with or without HDR10+ selected, enabled and disabled, nothing changed in Infuse or in playback, so just hoping is a bug because I don’t have anything more to try :sweat_smile:

If it’s just these 2 files you are having trouble with, then there may be something about them that is causing an issue.

If you’re able to upload one of the problematic files we can take a look.

Files up to 50GB can be uploaded here.

1 Like

Hi, I think I discovered what it is and it has nothing to do with playback. I tried copying it in another type of share (Samba) and it worked, so I checked again in the one that didn’t worked (Webdav) and still didn’t work. So I searched for something that both shared and could be problematic, so I removed the + sign of the HDR10+ in the filename, and it works now. Not sure why, because I can access the file from any other Webdav explorer, but at least there’s a quick fix for now.


Nice work, that’s interesting about the file names!