Am I stuck? JB 5.0.2



I’ve got a weird situation, so I’ve been running JB 5.0.2 for quite a while now.  Last night I unplugged my device (JB is untethered) and was working on a friend’s ATV2 and getting them JB with 5.2.1 (tethered).  While I was at it I hooked mine back up, still JB and ran an apt-get update and apt-get upgrade to check for any new packages.  A few updates to ssh etc were available and got installed, I’ve had my host file set to block Apple updates.  Anyway, I shut it down and when I turned it on today the JB was gone.  Tries SSHing in and connection was refused.  

My firmware is still 5.0.2, but I had never saved off any SHSH BLOBS, I tried SeasonPass 0.9.2 with saving the keys and then explicitly installing 5.0.2, everything seemed ok, and flashed without error, but when I went to re-connect it was still not JB.  I tried again, and this time in iTunes I got a 1643 error when it attempted to flash the IPSW.  

I did some more reading and saw people recommending using iFaith to grab the Blobs and Snowbreeze to merge the IPSW, I tried to pull the blobs with iFaith, but ended up with an error saying there weren’t any available- can you only pull blobs while it is actually jailbroken?  If that’s the case, how can I JB my device?  I believe it is still on 5.0.2, I have been careful not to let it upgrade to 5.2.1.

Thank you!


UPDATE: Well this is weird, I plugged it back in and now it is jailbroken…is it possible it actually took the JB when I got the 1643 error?  Now that it is JB again, what should I do to ensure I am ‘safe’?


NOW is the time to use Maintainance from FireCore to save your settings (read: blobs).  Take it from my experiences—it is simple to do and it WILL allow you to rebuild your JB system with the same version (5.0.2 in your case) through SeasonPass 0.9.2—follow the instructions carefully.