Always boots into recovery after jailbreak

AppleTV Gen2

SP Version 0.7.9 (265)

Mac OSX 10.7

iTunes 10.5.1

Trying to go to 4.3 (iOS 4.3 - 8F455) 

Started off with 4.2.1

I have done quite a big of hacking on my atv2 and I decided that a refresh was in order.  Since I was going to refresh the atv2, I might was well upgrade to 4.3. I have my SHSH blobs saved and tinyumbrella running in the background.  There are no issues with any of the steps.  The issue comes after iTunes tells me that the restore was successful and complete. I disconnect the USB, let it sit for a few, then plug in power and HDMI.  I get the blinking light onthe atv2 and the picture showing me that I need to plug it back into my pc (recovery screen I believe).


I even upgraded to 4.4 to see if a downgrade would solve the problem.  Unfortunately it didn’t.  I’ve replace all ipsw files and I just blew away my SP binary and downloaded a new one.


My next move is to try it on another computer.

EDIT:  Tried on a different computer and got same results


Is there anything that I could be missing?


FYI - I used the same USB cable to do an untethered jailbreak less than a month ago.

In the meantime, I reverted back to 4.2.1 and used greenpois0n.


Everything is working.  It’s a shame I can’t get this to work.


I’ll try again once 4.4 is untethered.

There should be no problem going to 4.3 even without SSH blobs as I believe that Apple is still signing it.

Your symtpoms siund more as if you restored the 4.4.x firmware.   Is there any chance that the wrong .ipsw file got restored?

First I directly downloaded the ipsw, tried that a few times.  Then I let seasonpass download the ipsw and tried that a few times.  I know that they were all 4.3.  I was able to jb a different atv this weekend with no issues.  I’m not going to revisit this until there is an untethered jb for 4.4.