All files moved to Other folder and metadata lost

A couple of days ago all my movies and TV Shows were moved to my Others folder and all the metadata was lost. Right before it happened there was a prompt from Infuse. I think it asked whether I wanted to use local metadata, but I’m not 100% sure.

I’ve tried refreshing metadata and scan for changes but it doesn’t seem to make any difference. I’ve got iCloud sync set to on, Metadata Fetching to on, Embedded Metadata to off.

The files are there on the harddrive and I can play them but it’s quite difficult to navigate although I only have about 150 movies/series episodes on the NAS.

I hope you can help me sort out what’s going on.

Let me know if you need more information.



It sounds like you’ve just experienced what happens when your device needs more memory than is currently available. When another app or the os needs additional memory the OS can delete parts from apps to get that extra. This happens sometimes when there’s an OS update.

Infuse will rebuild everything from iCloud for textual metadata and then re download the artwork. It may take some time but much faster than starting all over,

What device did this happen on?

This was on an ATV4K. I don’t have many apps installed on it. I basically only use infuse.

I looked at the storage on the ATV4K. It was around 4 GB as my nephew had installed a game that took up about 3 GB of space. I deleted it and it’s now less than 1 GB out of 32 GB, so I don’t think it’s a question of running out of space. Is there some way to find out whether that is indeed the case?

I’ve tried refreshing metadata again but it still doesn’t recognise any movies or TV Episodes.

It’s not the app storage memory that gets wiped its the unlisted memory for settings and such. There’s no current way to look at that segment. If launch Infuse and go right to the Settings > Library screen where it shows Movies, TV shows and other it should have a message status below that. It should say something like “Syncing to iCloud” if you just let it sit there for a while it should start repopulating your movies and TV shows out of the others category. Depending on your internet speed and more so, the iCloud speed (which can drag now and then) it will restore everything.

It sounds like one or more of your folders may have gotten tagged to use local metadata.

If you browse directly through your folders in Infuse, do you see the words ‘Local Metadata’ in the upper right corner anywhere?

Ive been there for about 15 minutes now. I’ve got a 300 MBit fiber connection so I don’t think that’s the bottle neck.

I just tried “sync to iCloud” off and then on again. When I went to Library, it shortly said syncing to iCloud. That lasted about 5 seconds but there’s still only one file in Films and 134 in other.

Could it be that my iCloud metadata files go mixed up somehow?

Let it run until it shows the “Last Updated…” message.

When I go into the Other folder, all the files are listed in tile view. They all show the viewing progress in the top right corner but I don’t see anything about local meta data. But maybe I’m looking in the wrong place?

The entire problem started after I got a question about using local meta data. I’d never encountered that before. I think I just pressed yes. So that could explain why iCloud might have been updated with local meta data, if that’s what’s going on?

It does - it took less than 30 seconds

My bad. Yes, it does say Local Metadata. I was looking at the individual files but it’s there in the top right part of the screen.

The Local Metadata text would be visible while browsing the folder directly (not using the library).

If a folder is tagged to use local metadata, all online metadata will be removed and Infuse will generate metadata and artworks from the embedded info within the files.

The easiest way to fix this might just to delete the share and create a new one.

Otherwise, you can long-press on the folder icon and select the ‘Use Online Metadata’ option. You would then need to run the Clear All Metadata option in settings to get rid of the local metadata.

1 Like

Thanks, James!

I just deleted the share and am setting it up once more. It’s currently fetching meta data and everything looks fine :-).

Once again, thanks for the help.


Sorry I started you off on a wild goose chase. It sounded at first like you had got the metadata cleared notice when you started Infuse and that’s where I was coming from.

Glad ya got it sorted out now! :+1:

Thanks for the input, NC_Bullseye. I’m just glad it worked out :slight_smile:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.