AirPort Extreme USB hard drive not adding

Hi I can see my Airport Extreme in the shares menu but after putting in the credentials it gets stuck on the “Checking connection…” screen.

I am able to connect to the Airport hard drive from my Macbook so I’m confident that its the correct format (Mac OS Extended with journaling).


Are you using both a username and password to connect?

The AirPort Extreme requires a username of ‘admin’ along with the base station password.

I’m using ‘guest’ account on my AP Extreme when I connect from Infuse on iOS. But the same doesn’t work with tvOS. Is ‘admin’ a mandatory thing? The SMB on AP/TC doesn’t care about usernames with default settings, only if password is correct it gets you and admin rw access, and if no password is specified it’s a guest w/ ro access.

I haven’t tried ‘admin’ yet, since i thought the tvOS app is based on the same code and ended up using sftp, which has the same problem as iOS, the performance is very limited, i measured the speed on the server side, it’s 5-6Mbit/s top. I will add a separate post about it.

With most newer AirPort firmwares the username isn’t actually required, but it cannot be left blank.

We recommend using admin, but in theory you should be able to put anything there.

I have the exact same problem, but a slightly different configuration. My AirPort Extreme’ (AEX) password is set to “a” (NOT Wifi password of course). There is only one Wifi Network, setted up by an admin account from my Macbook Pro. I have really no idea what to test: i tested different passwords (changed them many times on the AEX machine), i tried many usernames (my admin name, “admin”, “Admin” and so on"). I even tried to set up the share manually. Still no fix :frowning:

Can you please help me? Just ask if you need any further information.

  • push - :frowning:

i could may add:

I can access the usb drive via Finder on my MacBook (admin account). I can’t access it via iPad inFuse App nor via ATV inFuse app. i tried various use drives, i formatted it FAT and Apple Disk Format (don’t know the exact name atm). I simplified the AirPort Extreme Password to one letter (NOT the Wifi password). i tried various names like “admin” etc.

Same problem, do anybody have an idea, what i could try? Does the disk should have any specific configuration?