Airplay with iOS 7


Before the IOS 7 update, I was able to stream youtube videos and photos form my iPhone and iPad, running Remote HD

After the iOS 7 upgrade, I cant seem to be able to do that anymore - I can actually send the youtube audio to the TV, but no video nor photos

I`m running the latest ATV Flash 4.5.1 with Remote HD 5 on the silver 1st generation ATV

I have the same set up and the same problem.  I can stream audio via airplay from my iOS device to the ATV, but no video, and on the iOS device I am not given the choice of video mirroring in  Control Centre / Airplay 


I can confirm that Airplay is apparently working correctly on the ipad/iphone as I can stream both audio and video (incl video mirroring) from the same iOS devices to other airplay compatible hardware.


I am also able to stream audio and video via airplay from my MacBook to the ATV, so it looks like the issue is specifically with iOS7.


Any workarounds?

I have the same problem. Streaming from Iphone with iOS7 to appletv and can’t streame any video at all. The AirPlay icon shows only a loudspeaker.

But in iTunes, i can streame videos to Appletv without any problems.

Is RemoteHD still active? There is nothing happend on their website??

Hi everyone, first time user to this forum. and Happy Holidays !!

Just to let everyone who had the same issue as you AND ME, I’ve managed to get my Iphone 5 working with the iOS 7, with the ATV 1st Gen.

I went to “launcher” on the usual cross media bar.

go to downloads and one by one downloaded and installed the updates.

the ones i had were

XBMC 10.1 - Dharma

XBMC 11.0 - Eden

Launcher 3.2.5


I went from top to bottom installing the updates, then the ATV reset itself after the last one.

Once it fired up again, i went to remote HD on my phone, and my 1st Gen ATV appeared in the list of devices,

So i swiped up the control panel on the iphone5 and airplay was available.

Im now listening to my music from my iphone’s library on the ATV… Christmas miracle!!


All the best for the new year!

Hi, does video streaming also work?

hi guys, audio has not been a problem at all

the problem is with video…have you been able to try video??

If you want vids either from YouTube or library (iPhone) videos, use XMBC app that came with the Remote HD USB hack.
Launch the XMBC and go to settings and allow anything that allows streaming, particularly airplay
Staying within the XMBC launcher select a vid on the phone and hit the airplay icon, you’ll have a choice to choose the XMBC… Then enjoy

Just tried it, worked a treat.

Now gone back to it. And does only audio now?? WTF

20mins later…

Ok so got it back,
On the ATV media bar , re download the launcher for XMBC in downloads (under launcher)
Then go back to XMBC app and play a video again… Note you may have to revert airplay output device as iPhone then back to XMBC , which now should have a TV screen in the logo.

I suppose this will just have to do until a fix comes along


just reinstalled the XBMC launscher and video straeming works again, no matter where you are on the Apple TV.

Yeah it work, for a while, and its not every video thats works. When I restart Appletv I have to disable/enable the H 264 option wich is controlled by the Perian(codec). Anyway its not sure I can play a HD video on Youtube. So I guess the problem is the Perian Codec. 

Are there anyone from FireCore who will take responsebility to fix the videoproblems. We have paid a lot of money to get aTV Flash, and I want the software to function proberly. So look into it and make som solutions FireCore.

Same issue for me, only audio streaming with airplay between iOS 7 devices and first gen atv using remote hd. I’ve re-installed XBMC and Perian, without success: only audio streaming…
Firecore please fix!

Same problem as the earlier posters.

No video, but audio fine. Just every now and then a video works though.



Anyone found a conclusive solution or work around to get video streaming working?



I have a the same problem. No video over AirPlay from iPhone 5s on Apple TV 1st gen.

[quote="stephanw.4303"] Hi, does video streaming also work? [/quote]

i also have the same problem, no video, please fix this , the airplay is the reason i bougth this software

 no streaming video not working



 Hope they'll fix soon.. just bought an apple tv since i thought airplay was fully working >.<

Another nudge...

Firecore, the issue appears to be widespread and there are many of your customers that are looking for a solution.... This thread has now been viewed >5,000 times.  We would be very grateful for some feedback:

- Is a solution technically possible?

- If so, can we realistically expect Firecore to provide such a solution?

The ATV1 continues to be a brilliant device for those of us who don't or can't leave a paired computer on all the time.  AirPlay is a fantastic additional feature made possible through ATVFlash and Remote HD, but it is really frustrating that only audio feeds can be made to work from iOS devices with iOS 7 or higher.

Grateful for your attention

Deleted repeat post

I am informed by Firecore that this is an issue with RemoteHD and not ATVFlash.

I have tried to contact the makers of RemoteHD over a period of months via their support link but have received no answer.

I can only urge others who are also having problems with Video over AirPlay to an ATV1 to also contact RemoteHD support and perhaps we will get a response from them.

iOS8 is coming soon… will this solve the problem?

ok, I installed atvflash, twice with reset to factory in between. I can send AUDIO from iPhone 6 on iOS 8, but no video. I can send audio/Video from my mac with iTunes. My iPad (iOS 8) doesn’t even see the ATV (sees black atv).

Is this supposed to work or not?