Airplay Sound downgrade to DD 2.0

After update to infuse 7.4.10 (on iOS 16,3 devices)
All playback via AirPlay (to Samsung series 6uhd (2018) with sonos arc via hdmi arc) is downgraded to DD2.0
No matter what.
Same issue when I stream to Samsung series 6uhd 2022 with sonos ray via toslink)
This issue didn’t occure before 7.4.10 ( DD 5.1 was visible and noticeable ) option DD 5.1 via AirPlay is set to “on” .

Other apps provide DD 5.1 (plus) / DD 7.1 (plus) and even DD atmos if that is the sound tracks works like a charme .
What can be the issue?

Do your videos contain multiple audio tracks?

Can you try adjusting the audio track during playback to see if this helps?

Hi James,

Some do , some don’t… when they do have multiple audio tracks i try to reselect the DD5.1 or switch between the tracks.

No matter what I do it remains DD 2.0 bitstream as an input via AirPlay according to my tv .
Tried it with an iPhone 13 Pro, iPad 2021 / 2018 as a starting point for the AirPlay session. No matter what I select (audio track or 5.1 via AirPlay / 5.1 via HDMI options on or off ) . It alway s remains DD 2.0 as an result

Other apps via AirPlay can deliver up to 5.1 Dolby digital plus or even 5.1 Dolby digital Atmos
(Netflix up to 5.1 digital plus, Apple TV app up to atmos )
Infuse did do up to DD5.1 up until last update it seems …

Sadly this issue still remains. What can I do to get 5.1dd sound back ? Cause this is getting really annoying. Especially because it worked previously …