Again cannot connect Apple TV to iMac

Long time user who had no problem from when I started. Then, last year the connection from my ATV to iMac stopped working. After getting advice here nothing seemed to work but ultimately the problem went away when I renamed the iMac (I think that’s what fixed it). Now it’s back and I’ve tried everything I can thing of with no luck including changing the name of the iMac again.

I don’t think it’s a network connectivity issue because I can connect Infuse to Plex on the iMac and works perfectly. But when I look for Available Shares on Infuse I just get the spinning wheel. I tried manually adding the share using the local computer name (myname.local) and I triple-checked both the user name and password on Infuse and the sharing settings on the Mac (e.g. file sharing is on, SMB is checked).

I assume it’s a problem with SMB or authentication since Plex works and the file share doesn’t. I tried it on my iPhone and same issue.

Any ideas for me on where to look or what to check so I can solve this?

(I like using Infuse for certain videos that work better than on Plex.)

If you recently updated the iMac OS you may want to turn off File sharing, restart the iMac and then turn File sharing back on. There have been reports of OS updates causing the file sharing to lose it’s mind and the off then back on has fixed it.

Thank you. I tried that but no change. I still get “an error occurred” when trying to connect.

Here’s a post that runs through some other possible fixes after an OS update.

Thanks but I’ve covered all those items:

  • SMB enabled under Windows File sharing on my iMac
  • Folders added to list of Shared Folders on iMac
  • Current admin user/PW from iMac entered into Infuse