After update to 4.2 Infuse don't recognise TV-shows, anyone else?

This is very strange, the same files that the previous release nicely sorted and grouped nicely into seasons now just treats them as separate files… almost?!
If there are more than one season, Infuse will display one ‘folder/icon’ for the show. But when selected it will just display all episodes without grouping them in to seasons like before?
And those TV-shows I’ve got only one season they are lying around ungrouped in the root of my TV-show folder.

I’ve also noticed that the new Library view lists 0 TV-shows and displays these in the Other category…
I tried to switch to use local metadata, but it didn’t help…

All these files have a full set of Metadata, with the shows name, season, episode and more.
And the filenames also match the naming convention outlined inte the FAQ (Show.S01E01.mp4), and all these files have worked fine in all previous Infuse releases before 4.2.

I haven’t seen any other reporting this on the forum so I wonder what could trigger this?

Infuse does pick up the files metadata, it will display artwork and the episode description but it totally ignore that fact that it’s a TV-show…

Any ideas?

Ok… some more info here.
After switching of “Use local metadata” for the folder were I keep the TV-shows and then I made a rescan of the Library it worked.
So it looks like the interpreting of embedded metadata have been messed up with the new release…