After update infuse, the shared folder is not available

Apple TV infuse 6.2.4
macOS 10.15

After the update, the local network disappeared. At the same time, information about the shared folder was saved in favorites. But when you try to connect, it gives an error.

At the same time, everything works fine on the iPhone and iPad, and I can easily connect to the shared folder on mac.
that is, I did not change any settings, but on apple TV the shared folder is not accessible, and is available as before on ios

Should I wait for an update, or is there some kind of working solution?

1 Like

Welcome to the forum!

Not sure where you got it but Infuse 6.3 is not available or in distribution so you may want to check your versions again.

Yeah! 6.2.4, sorry.

Have you tried a restart on the ATV? Sometimes after updates things get out of whack a bit. Also I believe there was a recent tvOS update so a restart may help.

Yeah!
I rebooted Apple TV
I reset Apple TV
I uninstalled and reinstalled infuse
I tried to share another folder on mac
I tried creating a new user on mac

None of this helped.
The application for Apple TV does not see my mac

The iOS app is working properly.

1 Like

It sounds like you don’t have permissions set on the mac for the ATV to log into the mac. Are you trying to log into the mac as an administrator or as a created user? Sometimes trying to log in as admin causes issues that creating a user profile for the ATV will solve.

Also you may want to do a get info on the shared folder and make sure that at least read is authorized for the atv.

I am a computer administrator. In addition, I created another account. And also allowed guest access.
All users have read and write permissions to the shared folder.
The problem is not that I can’t access the folder, but that I don’t even see my computer on the local network
I tried to enter the address and login manually. I tried different combinations. As a result, a connection error always appears.
I tried other applications like PLEX or VLC and they work perfectly with the same folder

1 Like

Just trying to get an accurate understanding of what you’re seeing. So when you go to Settings in Infuse and then Network > Shares your mac is not showing up under the “Available Shares” section?

Yes.
This is from my iPhone

And this is from Apple TV

Both are the same network settings, but access to the folder is only on the iPhone…

In the end, I managed to solve the problem. But in a very strange way:
Apple TV settings -> network -> wi-fi -> manually specify DNS and IP for your router
I repeat that initially I had all the default settings and on other devices there is no problem
That is, the problem is not in the computer, but in the Apple TV. I think that the problem is in the last update of infuse or the update of TVOS.

Perhaps you can figure out exactly what happened. thx!

1 Like

Hm… The local network worked fine for 30 minutes and again disappeared from the list.
Strange, but my Mac sometimes appears in the list of available shared resources, but this happens randomly… I can’t establish a logical connection.

Yesterday I connected to the shared folder and started watching the movie through the infuse on Apple TV… but after 13 minutes watching - connection error appeared.
And after that, I again can not connect to the my shared folder on Mac…
There may be a problem in the router, but all the settings are set by default and before everything worked without problems

This is a DNS caching issue. I’ve seen it before. Usually a network issue. Don’t use host names but set static IPs for all of your “servers” that are hosting files. From there connect to them via IP.

I’m having this same problem since updating the software on my ATV 4.

We’ve seen a number of cases with the newer tvOS updates where the Apple TV will fall off the 5GHz Wi-Fi network, and start using 2.4GHz. This can cause issues with some routers, as there are issues with devices on different bands trying to communicate with each other. In particular, some Apple routers suffer from this.

As a test, what you can try is to create a dedicated 5GHz network, and ensure both Mac and Apple TV are connected to that (or use a dedicated 2.4GHz network) and see if things work as expected.

I have the same problem. I can see my shred folder, but when trying to enter I just get a message “acces denied”. I have my Apple TV attached to my Asus ax88u with cable, and the same with my iMac.

There are a few things to check.

  1. SMB is enabled on your Mac (more info here https://support.apple.com/en-us/HT204445).
  2. At least one user is selected under ‘Windows File Sharing’ (as shown under ‘Advanced Options’ in the link above).
  3. Selected username and password are being entered in Infuse.

Note: iCloud username/password cannot be used. If you’re using an iCloud ID to log in to your Mac, you will need to set up a new ‘Sharing Only’ user as described here: https://support.apple.com/guide/mac-help/set-up-other-users-mtusr001/mac

Also, if you’ve recently updated to macOS Catalina, you may need to disable and then re-enable File Sharing to get it working again.

Hi. I just had the same problem after updating to Catalina. At the end, disabling and enabling was the solution. What a… But thanks James again. You made my day :slight_smile: