After Seas0nPass 5.0 (iOS 5.1) only get "Computers" and Settings ?!

Followed all the instructions to update my ATV 2 and every time, using different Mac, I only get two icons: Computers and Settings (with the Firecore logo).

Did many little things but they don’t work… please help.

I saw on the blog page for the Apple (ATV2) 5.0 Update there is somebody with the same issue I have:

 

Anonymous (not verified)  Sat Mar 31, 2012 10:07 am

i have a jailbroken apple TV but it only shows computers and settings?? what can i do to show the other icons?? plz help

 

Do you an active wifi or ethernet connection? 

I’ve seen this behaviour on my non-jb’d ATV3. The cause, I think, is due to it not finding a network connection. I have my ATV plugged in via ethernet and when I viewed the network settings it had switched to wireless and wasn’t connected to a network. Unplugging and replugging the ethernet cable fixed it. I’ve also had it show it does have a valid ip via ethernet but still did not show the other options, sleeping and waking it up seemed to fix it in that instance.

I am unsure if this is expected behaviour of the software, but it does make some sense, as in if it cannot find an internet connection then it displays the computers option for home sharing, which would be on a local network.

Are you saying you are missing all the other icons and only those 2 are showing?

 

Seas0npass is only a jailbreak, it does not load on the extras.

 

If you want the extras then you need ATVFlash, but on 5.0 not all extras are supported yet for the new iOS

@Flipmode > Thanks, the issue is that "TV Shows" "Movies", "Music" and all the standard apps, like Netflix, YouTube…. are missing.

 

@utar50 > the ATV2 is connected through ethernet.

 

Thank you all.

@sharkus: Thanks you put me on the right pass !! 

 

The network was working, I had tested it. 

I also could stream from a my mac using "Computers" (network is working)

Tried disconnecting the ethernet and using wifi, didn't work.

As you advised tried putting it to sleep and waking it up, nothing.

 

THE ISSUE WAS:

 

Settings > iTunes Store > LOCATION

 

Needs to be set to "United States" !!!

 

When I inserted my Apple ID, it didn't set my Location to "United States" !!

 

Thank you all.

 

Best,

Thom

Glad to have pointed you in the right direction, and thanks for the update. It would seem that it’s probably trying to find the iTunes Store and if it cannot, for whatever reason, it’ll go into this fallback mode. Would be nice if it popped up a message of some sort indicating why it’s doing this.

Many thanks this worked for me as well!

I had the same exact problem as tvolponi and I realised my iTunes store settings wasn’t set. It was empty so I set it to US and I can see everything now. :slight_smile:

 

Cheers!

 

P.S. Am on the latest iOs 5.1.1.