After installing atv flash 4.4 (1g Apple TV), I can't setup anything.



A few days ago, I have purchased atv flash 4.4 (1g Apple TV) and then installed it onto my 1g Apple TV.

Installing was fine but whenever I tried to select setting such as Maintenace> install Extra, or Manange plugins ,or Nito TV > settings. etcs, Apple TV becomes very slow and then clashes. I have installed several times but the same things happen. 

How can I solve this problem?


I have the sane problem. Can someone help us? Thanks!

Same here. Also, when I look at the various plug-ins that are supposed to be installed automatically, they all say “not installed”. 


HELP!? :frowning:

Hmm - which version of AppleTV software are you running?

I just checked.I have 3.0.2 installed. Is that good or bad?

i’m having the same problem.

apple tv is connected to the network but for some reason once I install ATV flash i get errors and am unable to download anything.

i can’t search the web and more importantly i loose access to itunes store on the appletv.

is this supposed to happen?


Also having the same problem.

After installing the atvflash and then restarting the apple tv I get the beginning start up of the apple tv then the tv goes black.

I have the same problem, PLEASE!!! I need help. I can’t anything with my Apple TV 1st Gen


yup same here. We want our money back ! 

I got it working and here is what I did.

First I have the white apple tv box, so it is first generation.  

Second when I initially set it up I had a PC (I don’t know if this makes a difference, but I think so) Because now we run everything on a mac pro.  So I started up my pc and downloaded the 4.4 atv flash software onto the pc.  (Initially I had tried it on the mac and it did not work)

Third I have an external drive where we direct all the movies too.  I did not know if it was black because it could not read where to install the software.  The white apple tv only has one external usb port.  So I plugged in a usb hub with several ports and plugged in the external 1 Terabyte drive and the usb flash drive with the 4.4 flash software.

Then I ran it one more time, it may have been a couple of times, but I finally got back all the movies we have put on the apple tv and the new software worked.

In summary we had several variables going on and as I thought of everything and played with it then it came together.  Hope this helps someone.


So, I got mine working but it was a huge pain. Basically, I had to get satellite internet to speed things up. Then, I returned everything to factory stock. After that, I d/l’d the new version of ATV Flash and installed it. From then until recently, everything worked fine. Now, I’m having other issues.

What’s up with support the last few months…? They never seem to respond (i.e. Support). Weird.

yea, ive messaged them a lot but none of them have replied me yet !