After adding a super large Emby media library, Infuse has serious performance problems

Agree, it is a bad feature on IOS. Seems useless.

Back to the question, due to 200 items each pull from Emby server, for a 200k server, it costs more than 1 hour, so i have to keep infuse in the front and keep iphone screen awake.
If I open another application, it will interrupt loading index by Infuse because it is in the background.

No, I meant in the iOS settings under “General” > Background app refresh settings.

Will try but i dont think it is working. By the way, i am suing IOS 15… it can only let 3 or 5 applications in the background

I checked my background refresh settings, only few applications, less than 10, are on.

Try turning all but Infuse off.

Would also like to test this beta. Using Apple TV.

Invite sent.

Hi im also having the same issue on Apple Tv 4k 2021 with loading a 380k remote Emby library Infuse takes more or less 3h to scan the library at first sync (after a fresh install) but even though it is a long time it will be Ok if it weren’t for the fact that every time the you close the app and reopen it even when the syncing is finished scanning, Infuse Re-start the library sync again (new items added frequently to the emby server) and it las 3h again at that point i just start crying and the time go faster :).

Is there any solution for this or will the new beta solve this issue.? thnx

I will also like a beta test invite for my ATV

1 Like

Do you use the 32gb model or the 64gb model apple tv? If I remember correctly, you need more than 10gb free space otherwise tvos will start cleaning procedures which can potentially affect local library syncs. If this doesnt apply to you, try closing all other apps, disabling background refresh for all apps but infuse, deleting infuse, power cycling, reinstalling infuse, resyncing.

Thxs for the reply I have the 64gb version with only apple apps installed, i deleted all the bloatware
I did turned off background refresh for the only app that had it on (podcasts) and left only infuse On.I have deleted infuse many times and did all kind on reinstall even reset the ATv to factori and reinstall.
i have done all the things that you suggested numerous times with the same results. Tried metadata fetching on off with fries :fries: played with all settings i though could benefit this issue and nothing
Im writing here because im out of ideas wondering if some one had Infuse 7 with more or less 300k items remote library working correctly.
Every resync is 2-3h not only the initial sync

Do you have image cacheing set to disabled?

Yes and also tried with it enabled same result, keeps refreshing the whole library with any minor change or when I open the app

How do I get this Beta version. My 225,000 video library is taking 2-3 minutes to load each time I open Infuse

You can sign up here.