AFP-like Finder-Integration of AppleTV 2.4 with MacFuse and

After trying to activate AFP on AppleTV 2.4 without success I found a good replacement (Mac-only):

  1. Activate FTP and SSH on Your AppleTV using ATV-Flash.
  2. Download and install MacFuse on Your Mac: http://code.google.com/p/macfuse/ (free software, MacOS X 10.4 or 10.5 Intel or PPC required)
  3. Download and install Macfusion on Your Mac: http://www.macfusionapp.org/index.html (free software)
  4. Start Macfusion and create a new SSHFS-connection with the following preferences:
    Host: AppleTV.local
    Username: frontrow
    Password: frontrow
    Path: /Users/frontrow/Movies (or other path of Your choice)
    SSH Advanced: Port 22, Activate „Follow Symbolic Links“
    Extra Options: -o idmap=user -o uid=501 -o allow_root
  5. Finally mount Your AppleTV with Macfusion and use it like a normal MacOSX-Volume to copy files from and to AppleTV, rename or erase files, open files and preview or watch movies on Your Mac.
    The AppleTV can be mounted very conveniently from the Menubar when this option is activated in Macfusion’s Preferences.
    On my computers this solution works much faster than all other ftp-clients I’ve tried, and it’s much more Apple-like.
    Henner

UPDATE: When You use SnowLeopard, the current version of Macfusion does not connect to AppleTV. Here is the solution to fix it:
http://rackerhacker.com/2009/08/28/fix-macfusion-on-snow-leopard/

this is awesome thanks!
However do you know how i can modify the permissions on EXISTING files that were already in the folder when i set this up? I cannot modify permissions in finder.

I didn’t not get this app to work on Snow Leopard or Leopard with the following instructions.

I got this working on Snow Leopard as described. The only trouble I had was that “appletv.local” as the address did not work which is weird because it works with cyberduck. I had to use the IP address of the AppleTV instead and it worked just fine. I really like it. I can now export movies from iMovie directly to the AppleTV instead of a 2 step process. Very Cool! Thanks for the tip.

Doesn’t seem to be working anymore after installing ATV 3.0 and atvFlash 4.0
Well it was great for a day. Hopefully we can get it working again. It’s a great feature.

Update-
My Mistake
My IP address reset to DHCP from manual, so I was trying to connect with the wrong address. It still works. Still doesn’t work if I use “AppleTV.local”, but certainly not an issue.

From elsewhere, but follow these instructions. You will need to change permissions on the relevant folders to copy the new files to them.

The files you need are here <edit - link removed> - [color=#BF0000]Please do not distribute these files here.[/color]

Okay, here goes, the files above are from a 1.0 dmg.

from sbin directory…

mount_afp

from System>Library>Filesystems…

Appleshare directory and its’ contents.

Please note - To enable write access of the root account, run the following…

sudo -S mount -uw /
sudo -S touch /.readwrite
sudo -S sync

Copy mount_afp to the sbin directory…

Copy Appleshare directory and its’ contents to System>Library>Filesystems

I did this with Cyber duck, but had to change folder permissions in Terminal then use Cyberduck?

Create a symbolic link from AppleShare/afpfs.kext to afpfs.fs in /System/Library/Filesystems on Apple TV, run the following command…

cd /System/Library/Filesystems
sudo ln -s AppleShare/afpfs.kext afpfs.fs

To then set owner and permissions, run the following…

sudo chmod -R 755 /System/Library/Filesystems/Appleshare
sudo chmod +x /sbin/mount_afp
sudo chown -R root:wheel /System/Library/Filesystems/AppleShare
sudo chown root:wheel /sbin/mount_afp
sudo chmod +s /System/Library/Filesystems/AppleShare/afpLoad

That works perfectly for me…

this MacFuse + MacFusion solution works flawlessly. Super thanks for the tutorial.