Adobe Flash & AppleTV 3.x - Updated: 1/28/2010

[b]--Updated 1/28/2010--[/b] Unfortunately Adobe Flash will not be supported in Couch Surfer Pro when running AppleTV 3.0 or later.

The AppleTV 3.0+ software includes a highly customized version of Webkit. WebKit is used for many system functions including media playback, cover art display, searching and of course web browsing. Unlike previous versions, this version has disabled Netscape type plugins such as Adobe Flash, Quicktime and Silverlight. We spent many hours attempting to recreate a new version of WebKit that would allow for enabling these plugins while retaining the normal functionality of the AppleTV.

After 3 months, and an enormous amount of research, development, and testing all attempts to create a new modified version of WebKit resulted in lost features and system instability. It's apparent at this point that due to the highly customized nature of the AppleTV that creating a set of WebKit frameworks that will support Adobe Flash while maintaining a normal operating system is next to impossible.

We'll continue to research alternatives to enabling Adobe Flash and will post any updates here.

Note: Adobe Flash can be viewed in Firefox after enabling Flash as described here: http://support.firecore.com/entries/259320

[b][Update 3/8/10][/b] Even with Adobe Flash properly enabled, Flash video performance in Firefox may still be less than ideal due to the AppleTV's limited processing power.

Ok. this may seem dumb, but, were do i access the firefox browser from. I cant seem to find were to get the thing opened?

 

it says its installed and i rebooted?

When installed, Firefox will be visible through the nitoTV --> Applications menu.

This menu will be hidden by default, but can easily be enabled through the nitoTV --> Settings --> Categories menu.

so i pretty much wasted 50 fucking dolars on atvflash just so i could play netflix on my old apple tv. installing WMV does nothing.   thanks for stealing my money assholes.

RE: keyboards. you need to make it clear it will not work with bluetooth keyboards, only RF

I CANT EVEN OPEN FIREFOX. the mouse freezes,  silverlight/adobe wont work, cant watch netflix. the nintendo doesnt work. ect ect ect ATVFLASH SUCKS

 So - for all of you who bought atvflash to watch video content on the net which uses adobe flash player (using CouchSurfer or Firefox plugin) : it's not working - though I suppose the team is working on it ever since I bought it from firecore 1 year ago.

Until then I downloaded every upgrade and went through the process discribed to run the flash player - to no success. Maybe it would be helpful for customers to mention the incabibility of using adobe's flash player with atvFlash as there might be others not getting what the have thought for - "unlimited" webbworsing using atvFlash stays a wish until now.

All the best for getting it working!

 

When I uploaded atv flash to my apple tv I didnt see the applications button to download Mozilla Firefox. What should I do.

thanks

bcm970015 suppose to support adobe flash 10.1. has anyone tried that with firefox? how is the flash video performance (youtube 720p etc.)?

Hi - I followed your detailed instructions to install Adobe Flash on my ATV1. That is I bought an unlicenced copy of Mac OSX 10.4.10 Tiger (Intel), using Pacifist I extracted the 'CoreAudioKit.framework' folder (a process which required me to copy it first from Pacifist to a clean USB drive and then FTP it to the documents folder in my AppleTV. 
I checked to see if Adobe Flash was installed on my ATV1 and it said that it was. I then when to the BBC News website and tried to view some videos in Flash. It told me that my version of Flash was not up-to-date (not surprising since your instructions on how to do this were dated September 10 2010) and directed me to the Adobe Flash website to download this. But naturally this does not download. So what do you recommend I do? How can I update the version of Flash on my ATV1?

You said: 

Hi, after copying the framework to the AppleTV you will need to re-install Adobe Flash through the menus.

Try this.

1. Navigate to the Maintenance --> Install Extras menu. 
2. Highlight the Adobe Flash item and press the right arrow to remove it. 
3. Restart the AppleTV when prompted. 
4. Go back to the Install Extras menu and re-install the Adobe Flash item.

-FireCore Support 

So I  followed your instructions. The AppleTV wants to download Adobe Flash Version 10.1.53.64 

But if I want to view stuff with Adobe Flash I am told by the Adobe website I need 
Adobe Flash 10.3.183.17

How can I get it to get this upgrade?

You said:

 

, there is very limited support for Adobe Flash on the ATV1 and full details for enabling it can be found here.

http://support.firecore.com/entries/259320-enabling-adobe-flash

I said":

 

That does not deal with my problem and your support information is out of 
date. The 'full details' you mention are a support message from two years 
ago. My problem is that your Install Extras menu defaults to update to Adobe 
Flash Version 10.1.53.64 But if I want to view stuff with Adobe Flash I am 
told by the Adobe website I need Adobe Flash 10.3.183.17

This version of Adobe Flash was released after your support message was 
produced. There must be a mechanism to allow the Install Extras menu to 
update Adobe Flash to Version 10.3.183.17 which is the up to date release 
for Adobe 10 and people running Tiger on their AppleTVs

 

Following some extensive work Adobe have now upgraded everything to Adobe Flash 11. The version of Adobe Flash you require in April 2012 is now 11.2.202.228

But the ATV1 can only be upgraded to Adobe Flash 10 - to be precise the latest version of Flash for Mac OS X Tiger is 10.3.183.18, which is the version available through the Install Extras menu. So Firecore have come to the end of the road with this issue and it cannot be fixed. Best to make it clear to everyone that ATV1 in 2012 can no longer run Adobe Flash - possibly by something on the main website

I have read the article and i totally agree

:cry:

OK I am a total newb…ssooo please help me
I have just installed atv and I understand about the lack of adobe flash support…which I hope is fixed soon…
I cannot find where to access couch surfer???..according to the screens where it is mentioned … it is installed…and I have the latest version…but I do not have the INTERNET menu option that is referenced in all the web screen shots to actually get to it.
I dont get much time to scroll thru all the menus as my wife wants to watch the tv
Have I missed installing a plugin or something???
Help and be gentle please…I am a newb

In the 3.x AppleTV software Couch Surfer will appear as ‘Browser’. If not installed, Couch Surfer can be downloaded through the Maintenance > Manage Plugins menu.

I had already installed Adobe Flash before I saw this wiki article. I have since gotten a copy of the correct CoreAudioKit.framework file. My problem is that I can’t reinstall Adobe Flash. Is there a way to uninstall Adobe Flash or force ATV to use the new CoreAudioKit.framework another way?

Thanks.

Bill

I know the correct version of CoreAudioKit.framework can not be distributed on this site; however, I was wondering if someone could point me in the right direction to find this file so I can install it on my ATV. I installed ATV Flash about three weeks ago and have had no luck locating this file. Any help would be greatly appreciated!!

Thanks,
Mark

Don’t waste your life looking for it, it doesn’t work!