Adding same files over and over


I am using Infuse Pro on Apple TV. My media files are located on a QNAP TS-563 NAS in RAID 5 with 4 x 8TB drives.
I have about 180 movies and about 7500 TV files.
I have just started with a clean install having just redone the NAS, previously it was JBOD.
My issue is that everytime I add a couple of new files, it completely re-indexes the entire contents of about 7800files. It’s done it 4 times now and now it says I have almost 32,000 files.
When I open TV shows or movies there is still only the one copy showing.
The indexing also takes a long time as it does everything including metadata etc.
I also use a Windows 11 PC to access my NAS but watch everything via Apple TV and Infuse.
Any advice greatly appreciated.

QNAP NAS creates a “SNAPSHOT” of each of the Main Folders every 24 hours to be used as the Restore Point in the event of a drive failing. That folder contains a “copy” of sorts of each file. So after 4 days of Snapshots I had what looked like 5 copies of each file.
The solution was to exclude the Snapshot folder from the Library.
To do this I added the Parent Folder to Favourites, then Added the Snaphot folder to Favourites, then turned off the Snapshot folder from Favourites. Whilst as it I did the same for the Recycle Bin folder.
Solved no more duplicates and eternal indexing

How are you connecting to the NAS? DLNA, UPnP, SMB, etc

I’m using SMB

Are you using the network name of the NAS (like MyNAS.local) or are you using a fixed IP like

I am using the network name on the NAS. It shows as “MyName-QNAP”
On the PC I was having troubles with Windows 11 not showing any devices in the My Network so I allocated the NAS a static ip address in my router and have added the Network Drive to My PC via that.

You may want to try using the static IP instead. I remember something about when using the name the first time it was accessed the nas added a number to the name and each time after for some reason it added a new number after. I don’t recall exactly why but it was making it look like multiple copies of the same NAS.

Have you let it complete the scan to see if it corrected the number of files?

If you go to library settings do you see more than one share/favorite listed?

No just the one entry for each of the two folders, Movies, Tv Shows

NC_Bullseye - For some reason it didn’t like the static ip address option, gave me an error.

@NC_Bullseye I’m wondering if it might have something to do with QNAP’s Snapshot feature which is sort of like a restore point. I’m wondering if each time there is a snapshot if infuse can see it and therefore creates a new index.
I looked in the Library folder and 4 copies of each show were displayed.
I’ve then done a full Forget Share and tried to start again and it immediately listed 32,000 files, which is 4 x what I have.
Is there a way to exclude the “snapshot” sub folder from within both Movies and TV Shows??

I’m not familiar with the Qnap NAS but that sounds like it’s where your multiples are coming from.

The Synology has a “trash bin” where it places deleted items “just in case” you make an oops and want to get the file back but that feature also caused multiples since the bin was inside the same directory as the video files. I just turned that feature off and all the duplicates went away.

I’d see if the Qnaps allows you to turn off that feature for your media directories if you need it for other than Infuse or turn it off completely if you only are using the NAS for streaming from.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.