Adding folder artwork to TV series no longer works

Having the same issue.
Follow the instructions to the letter but the season posters are always downloaded from tvdb no matter what i do.
Not even folder.jgp works when it’s series. Works like a charm on single movies though.

Everything works fine in the ‘Movies’ library.
Things are messed up for the ‘TV Show’ library regardless of what I do. I am going to leave it alone and wait for firecore to resolve the issue. It used to work for me and I’ve changed nothing. I’m going to wait to see if the next version puts things back the way they were before 6.1.

Please try this and let me kow if it works as this is what works fine for me:

  1. Activate Library mode to scan and work for the folder on your share that holds all of your TV Shows.

  2. Within the folder that contains the TV Show Season Folders (the TV Show collection root folder - so for example the ‘Game of Thrones’ folder) put here all of your custom folder artwork (‘poster.jpg’ for the main collection, ‘season 1-poster.jpg’ and onward for each season folder, but ensure you also put these in the root folder and not each season folder).

  3. Go to the TV Show collection folder (example ‘Game of Thrones’) and long press, select Edit Metadata, now select the correct TV Show from the proposed shows and your custom artwork should take over the TVDB artwork.

That’s 3 easy steps worth trying before you give up.

‘1) Activate Library mode to scan and work for the folder on your share that holds all of your TV Shows.’

Can you elaborate on this point as I don’t know what you mean or how to do it?
Thanks

1 Like

There’s a good chance that the problem is with tvdb. They had a major problem over the weekend and they’ve had to totally rebuild the cache for their servers.

https://stats.fireco.re/

Give it a day or two to calm down a bit and see if you get the right metadata. I guess since tmdb had their problems a week ago now tvdb felt left out. :slight_smile:

Hi Neil,
I’m home now and had chance to take a better look and write the guide better. I assume you are accessing your TV Shows using a Favourites link on your Home page. I don’t like or use the actual Library mode for TV Shows, but you need to activate it to use custom artwork. If so then this will work as this is the only way I managed to get custom TV Shows artwork to keep it consistent and not have to deal with the randomness that it selects from tvDB,

Try this:

  1. Activate the Infuse Library mode to scan and work for the folder on your share that holds all of your TV Shows. To do this go to the Cog icon in the upper right of the Home screen. In here select Library. Within the Library page you should see ‘Show Library’ - make sure this is on (with a tick). You should also see all and any Favourite shares in a section at the bottom of the Library page. I see all of my SMB shares from my NAS. Make sure the folder that holds your TV Shows has a tick next to it.

  2. On your share (PC or NAS) within the folder that contains the TV Show Season Folders (the TV Show collection root folder - so for example the ‘Game of Thrones’ folder) put in there all of your custom folder artwork. Ensure you put your custom art in the root folder and not into each season folder.

share:\TV Shows\Game of Thrones
poster.jpg (this will be the poster for the TV Show collection folder)
season 1-poster.jpg (these will be the posters for the individual seasons)
season 2-poster.jpg
season 3-poster.jpg

Also within here will be your individual season folders, and so all together it will be:

share:\TV Shows\Game of Thrones
poster.jpg (this will be the poster for the TV Show collection folder)
season 1-poster.jpg (these will be the posters for the individual seasons)
season 2-poster.jpg
season 3-poster.jpg
\season 1
\season 2
\season 3\

  1. Next back in Infuse go into the TV Show you have put custom artwork within (example ‘Game of Thrones’) and long press on season 1. When the mini menu appears select Edit Metadata, now select the correct TV Show from the proposed shows to the right side of the screen (it should already be highlighted on the correct tv show, so just select it again) and your custom artwork will take over the tvDB artwork.

I hope you do try this and I hope you have success like me because it’s the one part of Infuse that has irritated me the most.

Let me know how you get on! :slight_smile:

Thanks! Number 3 does the trick. I had to choose a season and edit Metadata to make it work. On the Ipad i Choose an episode. This corrected everything.
Many thanks.

Great! I’m glad it helped somebody out! Enjoy your custom artwork on TV Shows! :slight_smile: :slight_smile: :slight_smile:

Also, tvdb is back up now.

I’ve actually bought Infuse Pro version 5 and this has sorted the problem. I didn’t need to change the location or naming of any of the files I had before.

Just curious as to why would you buy version 5? There are so many improvements in 6 not to mention ongoing support and updates future upgrades.

Many of your problems were most likely caused by tvdb being down (and still having problems as recently as yesterday) I believe your problems would have resolved on their own once tvdb got back to full steam.

I bought version 5 because I know it works (with my file structure). Will check version 6 when I get home but if it’s not working then 5 is good enough for what I need.

This doesn’t work for me. It does in the movie section but not in the TV section. I’ve pretty much given up with this now and leaving it with the default TVDB artwork.

I tried this in my infuse pro 6. I tried to rename to artwork, poster and even same name folder but still artwork for tv series is not working. Image is from tvdb.

Post a screenshot of your current folders showing the artwork locations, names, and such.

Also, do you have the directory ticked under the Library settings in Infuse?