Added support for purchased iTunes content (matching iTunes login required)


What exactly does this mean? That i no longer have to use iTunes for all my contents if its stored on my NAS?

Can I now play these through the media player?

Yes, as long as your Apple TV is properly authorized for the content you wish to play, both DRM and non-DRM media can be streamed directly from a NAS drive. No iTunes required.

Yippee! Thanks James, no more PC needed to be on!

Dont suppose there is a way to import your current playlists as per iTunes so as I dont have to rebuild them on my NAS?

No support for iTunes playlists just yet. Hopefully we can add these at some point in the future.

Could anyone please give some more information about this feature? I put purchased Itunes DRM content on my NAS and a can play it through the Media Player. However, starting a movie takes some time (much more than with non-DRM content) and pressing and holding the centre remote button does not have any effect. Apart from that, there is no difference whether I am locgged in the Itunes store or not.

Have I overlooked something?

Thank you for feedback

While aTV Flash (black) allows you to stream purchased files directly from a NAS drive (instead of iTunes) the files will then be sent to the default Apple TV player. Unfortunately the default player does not support things like external subtitles. Sorry.


just tested to play a copy of my purchased Series from a NAS. I am getting the error message that Authorization is required and that I have to enable this device. The Apple TV was already connected with my Apple ID and I can see my songs on iTunes Match. 

Please Help

Was the video purchased using the same Apple ID that is currently setup on the Apple TV?

Yes. Yesterday I tried a complete restore and now it is working. I have no idea what the problem was…

Strange. Glad you’re up and running now though.

The first time when I installed the jailbreak and aTV I did it on another Mac (same Apple ID, same Movie for testing). There it was working. As I connected the ATV in my home network to play the same movie (not the same file) I got that error message. 

OK, next problem. Today I bought another Serie (Fringe) and I copied the season to my NAS. Tried to play it with the aTV Media Player -> Error Message: Authorization required…

The Serie (Mentalist) I copied after the restore is still working. Any idea??? 

Hmm, and these were both purchased with the same iTunes account?

The best option may be to send in a bug report.

UPDATE: Started my Mac and iTunes (same network) and it works (Playing files from the NAS). Shutting down my Mac now and I will report if it is still working tomorrow :-).

OK, when one episode was finished I was not abel to play the next one. After I disconnected the ATV from power I am having the same problem with te other series -> Bug Report :frowning:

Hi, hoping someone can help. I’ve been playing apple purchases (TV and Movies) from a NAS as opposed to iCloud as I have a UK and a US iTunes account and didn’t want to switch back and forth all of the time. It’s been working great. But suddenly to totally stopped working and I get the ‘Authorzation is Required’ message. What have I done to it to make it stop working? Please help!

Just wanted to report that this feature does not appear to be working for me any more as well.  I have two ATV2’s one with the latest 2.0 upgrade, and one with the previous version.  Both of them are getting the same authorization required message.  This previously was working on both units.  Can’t tell you exactly when it stopped working, but can report that it is happening on both the current 2.0 and the previous version of the software.

When I experienced this problem I found that it was nothing that ‘I’ had done (nor software or hardware update), and searching online appeared to confirm it was an apple server side issue.

However, I do have several devices - iPhone, iPad, and aTV - all using the same apple log in credentials. And I did note (later, after much frustration with the aTV) that in fact the iPad seem to be having issues with logging in, and was continually demanding the log in credentials.

I have also noted this problem once or twice on subsequent occasions.

So my only suggestion is full reboots on all devices, making sure you are logged in properly on each device (both in settings, and in the various apps, iTunes, App Store, etc).

For me it didnt really seem like there was anything really wrong, it just seemed like some of my devices and/or the apple server, were ‘confused’. I hope this helps.

Looking into this…

How long does it take for you to look into it?